diff mbox series

[meta-python,2/5] python3-portion: Upgrade 2.2.0 -> 2.3.0

Message ID 20220914115833.177477-2-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/5] python3-imageio: Upgrade 2.21.2 -> 2.21.3 | expand

Commit Message

Leon Anavi Sept. 14, 2022, 11:58 a.m. UTC
Upgrade to release 2.3.0:

- Support Python 3.10.
- IntervalDict.as_dict has an optional atomic=False parameter that,
  if set to True, returns intervals that are atomic.
- Experimental support for structural pattern matching (on left,
  lower, upper and right).
- (breaking) For consistency, the empty interval is never <, >, <=,
  nor >= when compared to another interval.
- Comparing an interval and a value is deprecated since it is
  ill-defined when the value is on the left of <= or >=. Convert
  values to singletons first.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-portion_2.2.0.bb => python3-portion_2.3.0.bb}  | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-portion_2.2.0.bb => python3-portion_2.3.0.bb} (67%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-portion_2.2.0.bb b/meta-python/recipes-devtools/python/python3-portion_2.3.0.bb
similarity index 67%
rename from meta-python/recipes-devtools/python/python3-portion_2.2.0.bb
rename to meta-python/recipes-devtools/python/python3-portion_2.3.0.bb
index 0dad8b0ce..1638d64c3 100644
--- a/meta-python/recipes-devtools/python/python3-portion_2.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-portion_2.3.0.bb
@@ -7,6 +7,10 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05f1e16a8e59ce3e9a979e881816c2ab"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "b6bfb08a7834787aca076da1200b735d97beef61b60a462b05213e7354a099cf"
+SRC_URI[sha256sum] = "0e9d42838099263201b25517e4c1bd57042b5fe44432d6df38cef72d84d1eb1f"
+
+RDEPENDS:${PN} = "\
+    ${PYTHON_PN}-sortedcontainers \
+"
 
 BBCLASSEXTEND = "native"