diff mbox series

[meta-oe,1/7] libcdio: Define _LARGEFILE64_SOURCE

Message ID 20220912034123.1885229-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/7] libcdio: Define _LARGEFILE64_SOURCE | expand

Commit Message

Khem Raj Sept. 12, 2022, 3:41 a.m. UTC
This package tries to use fseek/fseeko/fseeko64 based on a local logic
where it sees a need to use largefile supported fseeko on 32bit however
is a transparent implementation of fseeko, so to get explicit
definitions of fseeko64/lseek64 etc. serve the definition on 32bit
architectures via cmdline

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-multimedia/libcdio/libcdio_2.1.0.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-multimedia/libcdio/libcdio_2.1.0.bb b/meta-oe/recipes-multimedia/libcdio/libcdio_2.1.0.bb
index 1facd47d8f..62004ac440 100644
--- a/meta-oe/recipes-multimedia/libcdio/libcdio_2.1.0.bb
+++ b/meta-oe/recipes-multimedia/libcdio/libcdio_2.1.0.bb
@@ -18,6 +18,9 @@  PACKAGECONFIG[cdda-player] = "--with-cdda-player,--without-cdda-player,ncurses"
 PACKAGECONFIG[cddb] = "--enable-cddb,--disable-cddb,libcddb"
 PACKAGECONFIG[vcd-info] = "--enable-vcd-info,--disable-vcd-info,vcdimager"
 
+# add -D_LARGEFILE64_SOURCE for 32bit targets
+CFLAGS += "${@['-D_LARGEFILE64_SOURCE',''][d.getVar('SITEINFO_BITS') != '32']}"
+
 PACKAGES += "${PN}-utils"
 
 FILES:${PN} = "${libdir}/${BPN}${SOLIB}"