diff mbox series

[meta-java,dunfell] classpath-initial-native: exclude BB_NUMBER_THREADS from sstate hash

Message ID 20220907170729.31035-1-virendra.thakur@kpit.com
State New
Headers show
Series [meta-java,dunfell] classpath-initial-native: exclude BB_NUMBER_THREADS from sstate hash | expand

Commit Message

Virendra Kumar Thakur Sept. 7, 2022, 5:07 p.m. UTC
From: Virendra Thakur <virendrak@kpit.com>

The sstate-cache for classpath-initial-native is not shareable across
multiple machines because the parallelisation configuration of Bitbake
is being embedded into the sstate hash of classpath-initial-native.

Exclude BB_NUMBER_THREADS from the do_install sstate hashing to avoid
this issue.

Commit message adapted from a5257d41f32812bc9426183cc8d2b6f07617b0d5.

Signed-off-by: Virendra Thakur <virendrak@kpit.com>
---
 recipes-core/classpath/classpath-initial-native_0.93.bb | 2 ++
 1 file changed, 2 insertions(+)

--
2.17.1

This message contains information that may be privileged or confidential and is the property of the KPIT Technologies Ltd. It is intended only for the person to whom it is addressed. If you are not the intended recipient, you are not authorized to read, print, retain copy, disseminate, distribute, or use this message or any part thereof. If you receive this message in error, please notify the sender immediately and delete all copies of this message. KPIT Technologies Ltd. does not accept any liability for virus infected mails.
diff mbox series

Patch

diff --git a/recipes-core/classpath/classpath-initial-native_0.93.bb b/recipes-core/classpath/classpath-initial-native_0.93.bb
index 7bb1ca1..0f97bea 100644
--- a/recipes-core/classpath/classpath-initial-native_0.93.bb
+++ b/recipes-core/classpath/classpath-initial-native_0.93.bb
@@ -28,6 +28,8 @@  EXTRA_OECONF += "\
 # Ensure tools.zip is not installed at same path as classpath-native
 EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial"

+do_compile[vardepsexclude] += "BB_NUMBER_THREADS"
+
 do_install:append() {
     # remove files clashing with classpath-native in sysroot
     rm \