diff mbox series

[meta-oe] makeself: added makeself as new recipe

Message ID 20220826195403.893639-1-jan.vermaete@gmail.com
State Under Review
Headers show
Series [meta-oe] makeself: added makeself as new recipe | expand

Commit Message

Jan Vermaete Aug. 26, 2022, 7:54 p.m. UTC
Based on the older recipe of intel-iot-refkit.

Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
---
 .../makeself/makeself_2.4.5.bb                | 29 +++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/makeself/makeself_2.4.5.bb

Comments

Khem Raj Aug. 27, 2022, 3:57 p.m. UTC | #1
On Fri, Aug 26, 2022 at 1:03 PM Jan Vermaete <jan.vermaete@gmail.com> wrote:
>
> Based on the older recipe of intel-iot-refkit.
>
> Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
> ---
>  .../makeself/makeself_2.4.5.bb                | 29 +++++++++++++++++++
>  1 file changed, 29 insertions(+)
>  create mode 100644 meta-oe/recipes-devtools/makeself/makeself_2.4.5.bb
>
> diff --git a/meta-oe/recipes-devtools/makeself/makeself_2.4.5.bb b/meta-oe/recipes-devtools/makeself/makeself_2.4.5.bb
> new file mode 100644
> index 000000000..e0dfc3dae
> --- /dev/null
> +++ b/meta-oe/recipes-devtools/makeself/makeself_2.4.5.bb
> @@ -0,0 +1,29 @@
> +SUMMARY = "A self-extracting archiving tool for Unix systems, in 100% shell script."
> +DESCRIPTION = "\
> +    makeself.sh is a small shell script that generates a self-extractable \
> +    compressed tar archive from a directory. The resulting file appears as \
> +    a shell script (many of those have a .run suffix), and can be launched as is.\
> +"
> +HOMEPAGE = "https://makeself.io/"
> +LICENSE = "GPL-2.0-only"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> +
> +SRC_URI = "\
> +    git://git@github.com/megastep/makeself.git;protocol=https;branch=master \

We generally use without user when anonymous access like
git://github.com/megastep/makeself.git;protocol=https;branch=master

> +"
> +
> +SRCREV = "5742be6410bfad2c619fb1e98bf795e8fa0913c7"
> +
> +S = "${WORKDIR}/git"
> +
> +do_configure[noexec] = "1"
> +do_compile[noexec] = "1"
> +
> +do_install() {
> +    install -d ${D}${bindir}
> +    install -m 0755 ${S}/makeself.1 ${D}${bindir}/

what is makeself.1 file containing, I wonder if its a manpage, if so
then it should
go into mandir

> +    install -m 0755 ${S}/makeself.sh ${D}${bindir}/
> +    install -m 0755 ${S}/makeself-header.sh ${D}${bindir}/
> +}
> +
> +BBCLASSEXTEND = "native"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#98482): https://lists.openembedded.org/g/openembedded-devel/message/98482
> Mute This Topic: https://lists.openembedded.org/mt/93278219/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/makeself/makeself_2.4.5.bb b/meta-oe/recipes-devtools/makeself/makeself_2.4.5.bb
new file mode 100644
index 000000000..e0dfc3dae
--- /dev/null
+++ b/meta-oe/recipes-devtools/makeself/makeself_2.4.5.bb
@@ -0,0 +1,29 @@ 
+SUMMARY = "A self-extracting archiving tool for Unix systems, in 100% shell script."
+DESCRIPTION = "\
+    makeself.sh is a small shell script that generates a self-extractable \
+    compressed tar archive from a directory. The resulting file appears as \
+    a shell script (many of those have a .run suffix), and can be launched as is.\
+"
+HOMEPAGE = "https://makeself.io/"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "\
+    git://git@github.com/megastep/makeself.git;protocol=https;branch=master \
+"
+
+SRCREV = "5742be6410bfad2c619fb1e98bf795e8fa0913c7"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 ${S}/makeself.1 ${D}${bindir}/
+    install -m 0755 ${S}/makeself.sh ${D}${bindir}/
+    install -m 0755 ${S}/makeself-header.sh ${D}${bindir}/
+}
+
+BBCLASSEXTEND = "native"