diff mbox series

[meta-python,v2] python3-twitter: Upgrade 4.8.0 -> 4.10.1

Message ID 20220825145712.26477-1-atanas.bunchev@gmail.com
State Under Review
Headers show
Series [meta-python,v2] python3-twitter: Upgrade 4.8.0 -> 4.10.1 | expand

Commit Message

Atanas Bunchev Aug. 25, 2022, 2:57 p.m. UTC
Upgrading python3-twitter to 4.10.1 and adding
missing RDEPEND requests-oauthlib

The license line in PKG-INFO was moved from row 8 to row 9.

Changelog:  (https://github.com/tweepy/tweepy/releases)

New Features / Improvements:
 - Add support for Direct Message typing indicator
   and read receipts
   - Add API.indicate_direct_message_typing and
     API.mark_direct_message_read
 - Fallback to "detail" response value for HTTPException message
 - Handle "error" key of response being a string in HTTPException
 - Add asynchronous interfaces for Twitter API v2
   - Add asynchronous.AsyncClient
     - Add async_lru as requirement for async extra
   - Add asynchronous.AsyncStreamingClient
 - Add support for reverse chronological home timeline
   with Twitter API v2
   - Add Client.get_home_timeline and AsyncClient.get_home_timeline
 - Update the User-Agent header based on AsyncStream.user_agent
   even if AsyncStream.session is already initialized/set

Bug Fixes
 - Fix AsyncBaseClient rate limit handling
 - Fix handling of StreamRule when passed in list to
   StreamingClient.delete_rules or AsyncStreamingClient.delete_rules
 - Add support for media_fields, place_fields, and poll_fields
   parameters for Client.get_list_tweets and
   AsyncClient.get_list_tweets
 - Ignore AsyncClient method parameters explicitly passed as None

Twitter API Deprecations:
 - Deprecate Stream.sample and note deprecation of compliance
   messages for Stream.filter
 - Deprecate AsyncStream.sample and note deprecation of compliance
   messages for AsyncStream.filter

Misc:
 - Use setup.cfg for coverage.py configuration
   - Explicitly specify coverage >= 4.4.2 requirement for dev extra
 - Use setup.cfg for tox configuration
   - Update lower bound for dev extra tox requirement to >= 3.21.0
 - Remove tests_require from setup.py
 - Stop creating universal wheels
 - Update and improve various documentation and tests
 - Log text of HTTP response when handling request error in BaseStream
 - Update Requests documentation URL for Intersphinx linking
 - Correct typo in documentation for StreamingClient and
   AsyncStreamingClient add_rules and delete_rules methods

Signed-off-by: Atanas Bunchev <atanas.bunchev@gmail.com>
---
 .../{python3-twitter_4.8.0.bb => python3-twitter_4.10.1.bb}  | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-twitter_4.8.0.bb => python3-twitter_4.10.1.bb} (62%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-twitter_4.8.0.bb b/meta-python/recipes-devtools/python/python3-twitter_4.10.1.bb
similarity index 62%
rename from meta-python/recipes-devtools/python/python3-twitter_4.8.0.bb
rename to meta-python/recipes-devtools/python/python3-twitter_4.10.1.bb
index 247b4e584..b283aef56 100644
--- a/meta-python/recipes-devtools/python/python3-twitter_4.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twitter_4.10.1.bb
@@ -2,9 +2,9 @@  SUMMARY = "Twitter for Python"
 DESCRIPTION = "Python module to support twitter API"
 
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=9;endline=9;md5=8227180126797a0148f94f483f3e1489"
 
-SRC_URI[sha256sum] = "8ba5774ac1663b09e5fce1b030daf076f2c9b3ddbf2e7e7ea0bae762e3b1fe3e"
+SRC_URI[sha256sum] = "310193775d7fc381abd6f37021a9af27f7e9edfcce5ec51bd73ea5f30c21fa61"
 
 PYPI_PACKAGE = "tweepy"
 
@@ -14,5 +14,6 @@  RDEPENDS:${PN} += "\
     ${PYTHON_PN}-pip \
     ${PYTHON_PN}-pysocks \
     ${PYTHON_PN}-requests \
+    ${PYTHON_PN}-requests-oauthlib \
     ${PYTHON_PN}-six \
 "