diff mbox series

[meta-oe,v2] gensio: upgrade 2.3.1 -> 2.5.2

Message ID 20220825142133.3336408-1-jlu@pengutronix.de
State Under Review
Headers show
Series [meta-oe,v2] gensio: upgrade 2.3.1 -> 2.5.2 | expand

Commit Message

Jan Lübbe Aug. 25, 2022, 2:21 p.m. UTC
Version 2.5.2 contains an include sys/unistd.h, which is not available
with musl, so fix the include path.

Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
---
 ...01-tools-gensiot-Fix-build-with-musl.patch | 29 +++++++++++++++++++
 .../{gensio_2.3.1.bb => gensio_2.5.2.bb}      |  6 ++--
 2 files changed, 33 insertions(+), 2 deletions(-)
 create mode 100644 meta-oe/recipes-connectivity/gensio/files/0001-tools-gensiot-Fix-build-with-musl.patch
 rename meta-oe/recipes-connectivity/gensio/{gensio_2.3.1.bb => gensio_2.5.2.bb} (85%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-connectivity/gensio/files/0001-tools-gensiot-Fix-build-with-musl.patch b/meta-oe/recipes-connectivity/gensio/files/0001-tools-gensiot-Fix-build-with-musl.patch
new file mode 100644
index 000000000000..93831c380f72
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gensio/files/0001-tools-gensiot-Fix-build-with-musl.patch
@@ -0,0 +1,29 @@ 
+From 823b6754a4d7655480b6e8576a9d0037f842d653 Mon Sep 17 00:00:00 2001
+From: Jan Luebbe <jlu@pengutronix.de>
+Date: Thu, 25 Aug 2022 12:19:16 +0200
+Subject: [PATCH] tools:gensiot: Fix build with musl
+
+According to POSIX getpid() is available in unistd.h, not sys/unistd.h.
+
+Upstream-Status: Submitted [https://github.com/cminyard/gensio/pull/47]
+Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
+---
+ tools/gensiotool.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/gensiotool.c b/tools/gensiotool.c
+index cac531bb4b74..ab0bb9583f9f 100644
+--- a/tools/gensiotool.c
++++ b/tools/gensiotool.c
+@@ -44,7 +44,7 @@
+ #include <signal.h>
+ #include <errno.h>
+ #include <sys/types.h>
+-#include <sys/unistd.h>
++#include <unistd.h>
+ #include <syslog.h>
+ #endif
+ 
+-- 
+2.30.2
+
diff --git a/meta-oe/recipes-connectivity/gensio/gensio_2.3.1.bb b/meta-oe/recipes-connectivity/gensio/gensio_2.5.2.bb
similarity index 85%
rename from meta-oe/recipes-connectivity/gensio/gensio_2.3.1.bb
rename to meta-oe/recipes-connectivity/gensio/gensio_2.5.2.bb
index a6e0075538c3..9de21209caf5 100644
--- a/meta-oe/recipes-connectivity/gensio/gensio_2.3.1.bb
+++ b/meta-oe/recipes-connectivity/gensio/gensio_2.5.2.bb
@@ -5,9 +5,11 @@  LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
                     file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
                     "
 
-SRCREV = "c500d8705c517f96e591c060105a789f053d2b7a"
+SRCREV = "b6cd354afe6d5f63bc859c94fd3a455a3cdf0449"
 
-SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=master"
+SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=master \
+           file://0001-tools-gensiot-Fix-build-with-musl.patch \
+"
 
 S = "${WORKDIR}/git"