diff mbox series

[meta-oe] yasm: Only depend on xmlto when docs are enabled

Message ID 20220824153539.423878-1-mac@mcrowe.com
State Under Review
Headers show
Series [meta-oe] yasm: Only depend on xmlto when docs are enabled | expand

Commit Message

Mike Crowe Aug. 24, 2022, 3:35 p.m. UTC
The yasm build system only requires xmlto when building its
documentation. It automatically detects whether it is present at
configure time.

Signed-off-by: Mike Crowe <mac@mcrowe.com>
---
 meta-oe/recipes-devtools/yasm/yasm_git.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Khem Raj Aug. 24, 2022, 4:05 p.m. UTC | #1
On Wed, Aug 24, 2022 at 8:35 AM Mike Crowe via lists.openembedded.org <mac=
mcrowe.com@lists.openembedded.org> wrote:

> The yasm build system only requires xmlto when building its
> documentation. It automatically detects whether it is present at
> configure time.


Does it also detect it from build machine ?
Perhaps better to turn the knob on and off explicitly as well for
determinism

>
>
> Signed-off-by: Mike Crowe <mac@mcrowe.com>
> ---
>  meta-oe/recipes-devtools/yasm/yasm_git.bb | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/meta-oe/recipes-devtools/yasm/yasm_git.bb
> b/meta-oe/recipes-devtools/yasm/yasm_git.bb
> index 044fcbea7..3dd382be1 100644
> --- a/meta-oe/recipes-devtools/yasm/yasm_git.bb
> +++ b/meta-oe/recipes-devtools/yasm/yasm_git.bb
> @@ -4,7 +4,8 @@ HOMEPAGE = "http://www.tortall.net/projects/yasm/"
>
>  LIC_FILES_CHKSUM = "file://COPYING;md5=a12d8903508fb6bfd49d8d82c6170dd9"
>
> -DEPENDS += "flex-native bison-native xmlto-native"
> +DEPENDS += "flex-native bison-native"
> +PACKAGECONFIG[docs] = ",,xmlto-native,"
>
>  PV = "1.3.0+git${SRCPV}"
>  # v1.3.0
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#98418):
> https://lists.openembedded.org/g/openembedded-devel/message/98418
> Mute This Topic: https://lists.openembedded.org/mt/93229252/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Mike Crowe Aug. 24, 2022, 5:28 p.m. UTC | #2
On Wednesday 24 August 2022 at 09:05:05 -0700, Khem Raj wrote:
> On Wed, Aug 24, 2022 at 8:35 AM Mike Crowe via lists.openembedded.org <mac=
> mcrowe.com@lists.openembedded.org> wrote:
> 
> > The yasm build system only requires xmlto when building its
> > documentation. It automatically detects whether it is present at
> > configure time.
> 
> 
> Does it also detect it from build machine ?

No, because of the recipe-specific sysroot it can't see my system version
of xmlto.

I have xmlto installed, yet log.do_configure contains:

checking for xmlto... no
configure: WARNING: xmlto not found, manpages will not be rebuilt.

> Perhaps better to turn the knob on and off explicitly as well for
> determinism

I couldn't find a --disable-doc/--without-xmlto knob otherwise I would have
done. :(

Or did you mean that I should explicitly set ac_cv_prog_XMLTO with
something like:

 PACKAGECONFIG[docs] = ",ac_cv_prog_XMLTO='',xmlto-native,"

?

Thanks.

Mike.
Khem Raj Aug. 24, 2022, 5:53 p.m. UTC | #3
On Wed, Aug 24, 2022 at 10:28 AM Mike Crowe <mac@mcrowe.com> wrote:

> On Wednesday 24 August 2022 at 09:05:05 -0700, Khem Raj wrote:
> > On Wed, Aug 24, 2022 at 8:35 AM Mike Crowe via lists.openembedded.org
> <mac=
> > mcrowe.com@lists.openembedded.org> wrote:
> >
> > > The yasm build system only requires xmlto when building its
> > > documentation. It automatically detects whether it is present at
> > > configure time.
> >
> >
> > Does it also detect it from build machine ?
>
> No, because of the recipe-specific sysroot it can't see my system version
> of xmlto.
>
> I have xmlto installed, yet log.do_configure contains:
>
> checking for xmlto... no
> configure: WARNING: xmlto not found, manpages will not be rebuilt.


That’s partly due to HOSTTOOLS now hiding majority of build system tools


>
> > Perhaps better to turn the knob on and off explicitly as well for
> > determinism
>
> I couldn't find a --disable-doc/--without-xmlto knob otherwise I would have
> done. :(


Ok I think it’s fine as it is since someone would have to explicitly add
xmlto to HOSTTOOLS to cause the issue


>
> Or did you mean that I should explicitly set ac_cv_prog_XMLTO with
> something like:
>
>  PACKAGECONFIG[docs] = ",ac_cv_prog_XMLTO='',xmlto-native,"
>
> ?
>
> Thanks.
>
> Mike.
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/yasm/yasm_git.bb b/meta-oe/recipes-devtools/yasm/yasm_git.bb
index 044fcbea7..3dd382be1 100644
--- a/meta-oe/recipes-devtools/yasm/yasm_git.bb
+++ b/meta-oe/recipes-devtools/yasm/yasm_git.bb
@@ -4,7 +4,8 @@  HOMEPAGE = "http://www.tortall.net/projects/yasm/"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=a12d8903508fb6bfd49d8d82c6170dd9"
 
-DEPENDS += "flex-native bison-native xmlto-native"
+DEPENDS += "flex-native bison-native"
+PACKAGECONFIG[docs] = ",,xmlto-native,"
 
 PV = "1.3.0+git${SRCPV}"
 # v1.3.0