diff mbox series

[meta-python,1/2] python3-coverage: Upgrade 6.4.1 -> 6.4.4

Message ID 20220822141828.2554564-1-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/2] python3-coverage: Upgrade 6.4.1 -> 6.4.4 | expand

Commit Message

Leon Anavi Aug. 22, 2022, 2:18 p.m. UTC
Upgrade to release 6.4.4:

- Wheels are now provided for Python 3.11
- Fix a failure when combining data files if the file names
  contained glob-like patterns
- Fix a messaging failure when combining Windows data files on a
  different drive than the current directory
- Fix path calculations when running in the root directory, as you
  might do in a Docker container
- Filtering in the HTML report wouldn't work when reloading the
  index page. This is now fixed
- Fix a problem with Cython code measurement

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-coverage_6.4.1.bb => python3-coverage_6.4.4.bb} | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-coverage_6.4.1.bb => python3-coverage_6.4.4.bb} (70%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-coverage_6.4.1.bb b/meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb
similarity index 70%
rename from meta-python/recipes-devtools/python/python3-coverage_6.4.1.bb
rename to meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb
index d352cdadf..5bff96901 100644
--- a/meta-python/recipes-devtools/python/python3-coverage_6.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://coverage.readthedocs.io"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
 
-SRC_URI[sha256sum] = "4321f075095a096e70aff1d002030ee612b65a205a0a0f5b815280d5dc58100c"
+SRC_URI[sha256sum] = "e16c45b726acb780e1e6f88b286d3c10b3914ab03438f32117c4aa52d7f30d58"
 
 inherit pypi setuptools3
 
@@ -13,4 +13,7 @@  RDEPENDS:${PN} += " \
 	${PYTHON_PN}-pprint \
 	${PYTHON_PN}-json \
 	${PYTHON_PN}-xml \
+	${PYTHON_PN}-crypt \
+	${PYTHON_PN}-shell \
+	${PYTHON_PN}-io \
 "