diff mbox series

[meta-python,1/2] python3-pyzmq: added ptest

Message ID 20220724143327.43832-1-jan.vermaete@gmail.com
State Under Review
Headers show
Series [meta-python,1/2] python3-pyzmq: added ptest | expand

Commit Message

Jan Vermaete July 24, 2022, 2:33 p.m. UTC
And update the summary and description from the github website.

Two tests are failing because cython is not installed.
But this is the same when running pytest under a native Linux system.

Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
---
 .../packagegroups/packagegroup-meta-python.bb |  1 +
 .../python/python3-pyzmq/run-ptest            |  3 +++
 .../python/python3-pyzmq_23.2.0.bb            | 25 +++++++++++++++++--
 3 files changed, 27 insertions(+), 2 deletions(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-pyzmq/run-ptest
diff mbox series

Patch

diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 0721c6c0d..1d2a9952c 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -515,6 +515,7 @@  RDEPENDS:packagegroup-meta-python3-ptest = "\
     python3-pyserial-ptest \
     python3-pytest-lazy-fixture-ptest \
     python3-pytoml-ptest \
+    python3-pyzmq-ptest \
     python3-requests-file-ptest \
     python3-requests-toolbelt-ptest \
     python3-scrypt-ptest \
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest b/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest
new file mode 100644
index 000000000..b63c4de0d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb b/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb
index 37ec9ec84..3471265e4 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb
@@ -1,4 +1,5 @@ 
-SUMMARY = "Pyzmq provides Zero message queue access for the Python language"
+SUMMARY = "PyZMQ: Python bindings for ZMQ"
+DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation."
 HOMEPAGE = "http://zeromq.org/bindings:python"
 LICENSE = "BSD-3-Clause & LGPL-3.0-only"
 LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e \
@@ -8,7 +9,11 @@  DEPENDS = "zeromq python3-packaging-native"
 SRC_URI += "file://club-rpath-out.patch"
 SRC_URI[sha256sum] = "a51f12a8719aad9dcfb55d456022f16b90abc8dde7d3ca93ce3120b40e3fa169"
 
-inherit pypi pkgconfig python_setuptools_build_meta
+inherit pypi pkgconfig python_setuptools_build_meta ptest
+
+SRC_URI += " \
+	file://run-ptest \
+"
 
 DEPENDS += "python3-packaging-native"
 
@@ -25,3 +30,19 @@  do_compile:prepend() {
     echo libzmq_extension = False >> ${S}/setup.cfg
     echo no_libzmq_extension = True >> ${S}/setup.cfg
 }
+
+RDEPENDS:${PN}-ptest += " \
+	${PN}-test \
+"
+
+PACKAGES =+ "\
+    ${PN}-test \
+"
+
+FILES:${PN}-test = " \
+    ${libdir}/${PYTHON_DIR}/site-packages/*/tests \
+"
+do_install_ptest() {
+	install -d ${D}${PTEST_PATH}/tests
+	cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/
+}