diff mbox series

[meta-python,2/3] python3-oslash: added the oslash Python package

Message ID 20220717173136.2777245-2-jan.vermaete@gmail.com
State Under Review
Headers show
Series [meta-python,1/3] python3-jsonrpcclient: Added the jsonrpcclient Python package | expand

Commit Message

Jan Vermaete July 17, 2022, 5:31 p.m. UTC
This is needed as rdepends of the python3-jsonrpcserver package in version 5.0.7.
Is should not be needed anymore in the 6.x version.

Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
---
 .../python/python3-oslash_0.6.3.bb            | 21 +++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb b/meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb
new file mode 100644
index 000000000..d9d977b70
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb
@@ -0,0 +1,21 @@ 
+SUMMARY = "Functors, Applicatives, And Monads in Python"
+HOMEPAGE = "https://github.com/dbrattli/oslash"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.md;md5=ed79d2637878dfe97de89e357b5c02dd"
+
+DEPENDS += "\
+    ${PYTHON_PN}-pip-native \
+    ${PYTHON_PN}-pytest-runner-native\
+"
+
+SRC_URI[sha256sum] = "868aeb58a656f2ed3b73d9dd6abe387b20b74fc9413d3e8653b615b15bf728f3"
+
+PYPI_PACKAGE = "OSlash"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+    python3-core \
+"
+
+BBCLASSEXTEND = "native nativesdk"