[meta-python,1/4] python3-eth-hash: Upgrade 0.3.2 -> 0.3.3

Message ID 20220706081940.1256838-1-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/4] python3-eth-hash: Upgrade 0.3.2 -> 0.3.3 | expand

Commit Message

Leon Anavi July 6, 2022, 8:19 a.m. UTC
Upgrade to release 0.3.3 and add runtime dependencies:

- Keccak backend was initialized every time it was called.
  Now it's initialized only the first time it's called.
- Prune venv files from the release via MANIFEST.in

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...python3-eth-hash_0.3.2.bb => python3-eth-hash_0.3.3.bb} | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-eth-hash_0.3.2.bb => python3-eth-hash_0.3.3.bb} (63%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-eth-hash_0.3.2.bb b/meta-python/recipes-devtools/python/python3-eth-hash_0.3.3.bb
similarity index 63%
rename from meta-python/recipes-devtools/python/python3-eth-hash_0.3.2.bb
rename to meta-python/recipes-devtools/python/python3-eth-hash_0.3.3.bb
index c9630b172..c4e8e5e51 100644
--- a/meta-python/recipes-devtools/python/python3-eth-hash_0.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-eth-hash_0.3.3.bb
@@ -4,6 +4,11 @@  SECTION = "devel/python"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=287820ad3553117aa2f92bf84c219324"
 
-SRC_URI[sha256sum] = "3f40cecd5ead88184aa9550afc19d057f103728108c5102f592f8415949b5a76"
+SRC_URI[sha256sum] = "8cde211519ff1a98b46e9057cb909f12ab62e263eb30a0a94e2f7e1f46ac67a0"
 
 inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+	${PYTHON_PN}-logging \
+	${PYTHON_PN}-pycryptodome \
+"