[1/7] python3-setuptools-scm-git-archive: add new recipe

Message ID 20220524121153.1175133-1-ross.burton@arm.com
State Under Review
Headers show
Series [1/7] python3-setuptools-scm-git-archive: add new recipe | expand

Commit Message

Ross Burton May 24, 2022, 12:11 p.m. UTC
Some Python packages use this at build time.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../packagegroups/packagegroup-meta-python.bb     |  1 +
 .../python3-setuptools-scm-git-archive_1.1.bb     | 15 +++++++++++++++
 2 files changed, 16 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-setuptools-scm-git-archive_1.1.bb

Patch

diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 6ca652e12d..bab637bfb2 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -389,6 +389,7 @@  RDEPENDS:packagegroup-meta-python3 = "\
     python3-send2trash \
     python3-sentry-sdk \
     python3-serpent \
+    python3-setuptools-scm-git-archive \
     python3-sh \
     python3-sijax \
     python3-simpleeval \
diff --git a/meta-python/recipes-devtools/python/python3-setuptools-scm-git-archive_1.1.bb b/meta-python/recipes-devtools/python/python3-setuptools-scm-git-archive_1.1.bb
new file mode 100644
index 0000000000..472c4eb1c8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-setuptools-scm-git-archive_1.1.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "setuptools_scm plugin for git archives"
+HOMEPAGE = "https://pypi.org/project/setuptools-scm-git-archive/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=838c366f69b72c5df05c96dff79b35f2"
+
+SRC_URI[sha256sum] = "6026f61089b73fa1b5ee737e95314f41cb512609b393530385ed281d0b46c062"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "setuptools_scm_git_archive"
+PYPI_SRC_URI = "https://files.pythonhosted.org/packages/7e/2c/0c15b29a1b5940250bfdc4a4f53272e35cd7cf8a34159291b6b4ec9eb291/${PYPI_ARCHIVE_NAME}"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"