[meta-oe] intel-speed-select: Add libnl dependency and extend CFLAGS

Message ID 20220509204353.9804-1-aryaman.gupta@windriver.com
State Under Review
Headers show
Series [meta-oe] intel-speed-select: Add libnl dependency and extend CFLAGS | expand

Commit Message

Aryaman Gupta May 9, 2022, 8:43 p.m. UTC
From: Randy MacLeod <Randy.MacLeod@windriver.com>

Add libnl dependency and extend CFLAGS to include the libnl3 directory.

Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
Signed-off-by: Aryaman Gupta <aryaman.gupta@windriver.com>
---
 .../recipes-kernel/intel-speed-select/intel-speed-select.bb    | 3 +++
 1 file changed, 3 insertions(+)

Comments

Aryaman Gupta May 9, 2022, 9:05 p.m. UTC | #1
Hi Bruce,

I'm working with Randy as a summer intern. We figured you may be interested in this commit. It's a simple change to add a dependency but strangely, it used to work for linux-yocto but recently started to fail for linux-yocto-dev. We noticed this discrepancy within the last week when rebasing wr-linux, where the genl.h file from libnl is present in the recipe-sysroot for linux-yocto but not for linux-yocto-dev (unless this dependency is added).  Randy and I are puzzled why this change showed up at this point; any ideas?

Regards,
Aryaman and Randy
-----Original Message-----
From: Gupta, Aryaman 
Sent: Monday, May 9, 2022 4:44 PM
To: openembedded-devel@lists.openembedded.org
Subject: [meta-oe][PATCH] intel-speed-select: Add libnl dependency and extend CFLAGS

From: Randy MacLeod <Randy.MacLeod@windriver.com>

Add libnl dependency and extend CFLAGS to include the libnl3 directory.

Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
Signed-off-by: Aryaman Gupta <aryaman.gupta@windriver.com>
---
 .../recipes-kernel/intel-speed-select/intel-speed-select.bb    | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/meta-oe/recipes-kernel/intel-speed-select/intel-speed-select.bb b/meta-oe/recipes-kernel/intel-speed-select/intel-speed-select.bb
index c895e6c1d..23ea0d8aa 100644
--- a/meta-oe/recipes-kernel/intel-speed-select/intel-speed-select.bb
+++ b/meta-oe/recipes-kernel/intel-speed-select/intel-speed-select.bb
@@ -11,10 +11,13 @@ inherit kernelsrc
 COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
 COMPATIBLE_HOST:libc-musl = 'null'
 
+DEPENDS = "libnl"
+
 do_populate_lic[depends] += "virtual/kernel:do_patch"
 
 B = "${WORKDIR}/${BPN}-${PV}"
 
+CFLAGS += "-I${STAGING_INCDIR}/libnl3"
 EXTRA_OEMAKE = "-C ${S}/tools/power/x86/intel-speed-select O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"

Patch

diff --git a/meta-oe/recipes-kernel/intel-speed-select/intel-speed-select.bb b/meta-oe/recipes-kernel/intel-speed-select/intel-speed-select.bb
index c895e6c1d..23ea0d8aa 100644
--- a/meta-oe/recipes-kernel/intel-speed-select/intel-speed-select.bb
+++ b/meta-oe/recipes-kernel/intel-speed-select/intel-speed-select.bb
@@ -11,10 +11,13 @@  inherit kernelsrc
 COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
 COMPATIBLE_HOST:libc-musl = 'null'
 
+DEPENDS = "libnl"
+
 do_populate_lic[depends] += "virtual/kernel:do_patch"
 
 B = "${WORKDIR}/${BPN}-${PV}"
 
+CFLAGS += "-I${STAGING_INCDIR}/libnl3"
 EXTRA_OEMAKE = "-C ${S}/tools/power/x86/intel-speed-select O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"