[meta-networking] libldb: Fix installed-vs-shipped and rebuild error

Message ID 20220424092756.107402-1-liezhi.yang@windriver.com
State New
Headers show
Series [meta-networking] libldb: Fix installed-vs-shipped and rebuild error | expand

Commit Message

Robert Yang April 24, 2022, 9:27 a.m. UTC
Fixed when multilib is disabled on intel-x86-64:
MULITLIBS = ""
$ bitbake sssd

ERROR: sssd-2.5.2-r0 do_package: QA Issue: sssd: Files/directories were installed but not shipped in any package:
/usr/lib/ldb
/usr/lib64/ldb/modules/ldb/memberof.so
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
sssd: 2 installed and not shipped files. [installed-vs-shipped]

And also remove bin/ got get a clean rebuild, otherwise, the rebuild result may
be incorrect.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
---
 .../recipes-support/libldb/libldb_2.3.3.bb            | 11 +++++++++++
 1 file changed, 11 insertions(+)

Patch

diff --git a/meta-networking/recipes-support/libldb/libldb_2.3.3.bb b/meta-networking/recipes-support/libldb/libldb_2.3.3.bb
index c46a9784e..6dd3ec3a9 100644
--- a/meta-networking/recipes-support/libldb/libldb_2.3.3.bb
+++ b/meta-networking/recipes-support/libldb/libldb_2.3.3.bb
@@ -68,3 +68,14 @@  FILES:pyldb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/* \
 FILES:pyldb-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug \
                    ${libdir}/.debug/libpyldb-util.*.so.*"
 FILES:pyldb-dev = "${libdir}/libpyldb-util.*.so"
+
+# Prevent third_party/waf/waflib/Configure.py checking host's path which is
+# incorrect for cross building.
+export PREFIX = "/"
+export LIBDIR = "${libdir}"
+export BINDIR = "${bindir}"
+
+do_configure:prepend() {
+    # For a clean rebuild
+    rm -fr bin/
+}