[meta-oe] mozjs-91: Add option to use system ICU

Message ID 20220420185449.2618610-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] mozjs-91: Add option to use system ICU | expand

Commit Message

Khem Raj April 20, 2022, 6:54 p.m. UTC
ARM needs to use system icu, otherwise build fails with gcc-12

firefox-91.8.0/intl/icu/source/common/stringtriebuilder.cpp:388: more undefined references to `std::type_info::operator==(std::type_info const&) const' follow
| collect2: error: ld returned 1 exit status

Keep using vendored ICU on mips since this breaks build for gjs
introspection code which is run under qemu-user

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Patch

diff --git a/meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb b/meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb
index d0accfaae4..af9256860c 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb
@@ -22,7 +22,8 @@  S = "${WORKDIR}/firefox-${@d.getVar("PV").replace("esr", "")}"
 
 inherit pkgconfig perlnative python3native rust
 
-DEPENDS += "zlib cargo-native python3"
+DEPENDS += "zlib cargo-native python3 icu"
+DEPENDS:remove:mipsarch = "icu"
 
 B = "${WORKDIR}/build"
 
@@ -39,8 +40,9 @@  export AS = "${CC}"
 export RUSTFLAGS
 
 JIT ?= ""
-
 JIT:mipsarch = "--disable-jit"
+ICU ?= "--with-system-icu"
+ICU:mipsarch = ""
 
 do_configure() {
     cd ${B}
@@ -52,8 +54,8 @@  do_configure() {
         --libdir=${libdir} \
         --disable-jemalloc \
         --disable-strip \
-        ${JIT}
-
+        ${JIT} \
+        ${ICU}
 }
 
 do_install() {