[meta-python] python3-wxgtk4: Require DISTRO_FEATURES as gtk3

Message ID 20220409085439.116819-1-liezhi.yang@windriver.com
State New
Headers show
Series [meta-python] python3-wxgtk4: Require DISTRO_FEATURES as gtk3 | expand

Commit Message

Robert Yang April 9, 2022, 8:54 a.m. UTC
It can't be built without gtk3:
No package 'gtk+-3.0' found

So make it have the same DISTRO_FEATURES as gtk3. It may also support gtk2, but
it depends on wxwidgets which doesn't support gtk2, so we don't have to
consider that.

And python3-wxgtk4 doesn't have PACKAGECONFIG, so remove the checking for
PACKAGECONFIG.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
---
 .../python3-wxgtk4/python3-wxgtk4_4.1.1.bb                | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

Patch

diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
index dcb373a1f..cbe3aedd1 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
@@ -4,10 +4,6 @@  HOMEPAGE = "http://www.wxpython.org"
 LICENSE = "WXwindows"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce1d18e2d633d41786c0a8dfbc80917"
 
-inherit features_check
-
-REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'no_gui', '', 'x11', d)}"
-
 DEPENDS = "wxwidgets-native wxwidgets"
 
 PYPI_PACKAGE = "wxPython"
@@ -20,7 +16,9 @@  SRC_URI[sha256sum] = "00e5e3180ac7f2852f342ad341d57c44e7e4326de0b550b9a5c4a8361b
 
 S = "${WORKDIR}/wxPython-${PV}"
 
-inherit pypi setuptools3 pkgconfig
+inherit pypi setuptools3 pkgconfig features_check
+
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
 
 export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR}'"