[meta-oe,v2,1/4] libimobiledevice-glue: add recipe

Message ID 20220331021648.16582-2-potin.lai@quantatw.com
State New
Headers show
Series add idevicerestore support | expand

Commit Message

Potin Lai March 31, 2022, 2:16 a.m. UTC
libimobiledevice-glue is the library with common code used by the
libraries and tools around the libimobiledevice project.

Signed-off-by: Potin Lai <potin.lai@quantatw.com>
---
 .../libimobiledevice-glue_git.bb                  | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb

Comments

Khem Raj March 31, 2022, 2:41 a.m. UTC | #1
On Wed, Mar 30, 2022 at 7:17 PM Potin Lai <potin.lai@quantatw.com> wrote:
>
> libimobiledevice-glue is the library with common code used by the
> libraries and tools around the libimobiledevice project.
>
> Signed-off-by: Potin Lai <potin.lai@quantatw.com>
> ---
>  .../libimobiledevice-glue_git.bb                  | 15 +++++++++++++++
>  1 file changed, 15 insertions(+)
>  create mode 100644 meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
>
> diff --git a/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
> new file mode 100644
> index 000000000..28303d082
> --- /dev/null
> +++ b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
> @@ -0,0 +1,15 @@
> +SUMMARY = "Library with common code used by the libraries and tools around the libimobiledevice project"
> +LICENSE = "LGPL-2.1"

can we use SPDX notation here please this would be LGPL-2.1-or-later

> +LIC_FILES_CHKSUM = "\
> +    file://COPYING;md5=6ab17b41640564434dda85c06b7124f7 \
> +"
> +
> +HOMEPAGE = "http://www.libimobiledevice.org/"
> +
> +DEPENDS = "libplist"
> +
> +SRCREV = "ecb0996fd2a3b0539153dd3ef901d137bf498ffe"
> +SRC_URI = "git://github.com/libimobiledevice/libimobiledevice-glue;protocol=https;branch=master"
> +
> +S = "${WORKDIR}/git"
> +inherit autotools pkgconfig

I also set PV to something definitive I see that its using 1.0.0 in AC_INIT see
https://github.com/libimobiledevice/libimobiledevice-glue/blob/master/configure.ac#L5

so perhaps use

PV = "1.0.0+git${SRCPV}"

> --
> 2.17.1
>

Patch

diff --git a/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
new file mode 100644
index 000000000..28303d082
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "Library with common code used by the libraries and tools around the libimobiledevice project"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "\
+    file://COPYING;md5=6ab17b41640564434dda85c06b7124f7 \
+"
+
+HOMEPAGE = "http://www.libimobiledevice.org/"
+
+DEPENDS = "libplist"
+
+SRCREV = "ecb0996fd2a3b0539153dd3ef901d137bf498ffe"
+SRC_URI = "git://github.com/libimobiledevice/libimobiledevice-glue;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+inherit autotools pkgconfig