polkit: Fix build with libtool 2.4.7

Message ID 20220324194949.1769445-1-scott.murray@konsulko.com
State Under Review
Headers show
Series polkit: Fix build with libtool 2.4.7 | expand

Commit Message

Scott Murray March 24, 2022, 7:49 p.m. UTC
Delete old m4 macros, so autoreconf can repopulate it.

Fixes

libtool: Version mismatch error.  This is libtool 2.4.7, but the
libtool: definition of this LT_INIT comes from libtool 2.4.6.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.7
libtool: and run autoconf again.

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
---
 meta-oe/recipes-extended/polkit/polkit_0.119.bb | 4 ++++
 1 file changed, 4 insertions(+)

Patch

diff --git a/meta-oe/recipes-extended/polkit/polkit_0.119.bb b/meta-oe/recipes-extended/polkit/polkit_0.119.bb
index b5f77700c..8a326a981 100644
--- a/meta-oe/recipes-extended/polkit/polkit_0.119.bb
+++ b/meta-oe/recipes-extended/polkit/polkit_0.119.bb
@@ -35,6 +35,10 @@  EXTRA_OECONF = "--with-os-type=moblin \
                 --disable-libelogind \
                "
 
+do_configure:prepend () {
+    rm -f ${S}/buildutil/lt*.m4 ${S}/buildutil/libtool.m4
+}
+
 do_compile:prepend () {
     export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
 }