[RFC,meta-python] python3-kaleido: Add a lightweight graphics library

Message ID 20220323234919.586572-1-mark.hatle@kernel.crashing.org
State New
Headers show
Series [RFC,meta-python] python3-kaleido: Add a lightweight graphics library | expand

Commit Message

Mark Hatle March 23, 2022, 11:49 p.m. UTC
From: Mark Hatle <mark.hatle@xilinx.com>

Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Signed-off-by: Mark Hatle <mark.hatle@kernel.crashing.org>
---
 .../python/python3-kaleido_0.2.1.bb           | 27 +++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-kaleido_0.2.1.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-kaleido_0.2.1.bb b/meta-python/recipes-devtools/python/python3-kaleido_0.2.1.bb
new file mode 100644
index 0000000000..3b95f3cb18
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-kaleido_0.2.1.bb
@@ -0,0 +1,27 @@ 
+SUMMARY = "Cross-platform library for generating static images"
+DESCRIPTION = "Kaleido is a cross-platform library for generating static images \
+(e.g. png, svg, pdf, etc.) for web-based visualization libraries, with a particular \
+focus on eliminating external dependencies."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=33ee0e1da4dbba9e5232bb1dcabfd47f"
+
+SRC_URI = "git://github.com/plotly/Kaleido.git;protocol=https"
+SRCREV = "624c30ca29b3a120215264b3b2e9341bf1bb4247"
+
+inherit python3native setuptools3
+
+DEPENDS += "python3-wheel-native"
+
+DISTUTILS_SETUP_PATH = "${WORKDIR}/git/repos/kaleido/py"
+S = "${WORKDIR}/git"
+
+DISTUTILS_BUILD_ARGS = "package"
+
+do_compile:prepend() {
+        mkdir -p ${S}/repos/build/kaleido
+
+        cp ${S}/README.md ${S}/repos/kaleido/.
+        cp ${S}/LICENSE.txt ${S}/repos/kaleido/.
+
+	python3 ${S}/repos/version/build_pep440_version.py
+}