[meta-networking,04/17] http-parser: Define LIBDIR

Message ID 20220320080815.825928-4-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,01/17] librdkafka: Use CMAKE_INSTALL_LIBDIR | expand

Commit Message

Khem Raj March 20, 2022, 8:08 a.m. UTC
LIBDIR is otherwise hardcoded to PREFIX/lib which is not correct for all
platforms. define PLATFORM explicitly, otherwise it pokes at build
system for it

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../recipes-support/http-parser/http-parser_2.9.4.bb          | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Patch

diff --git a/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb b/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb
index 122dfc0001..d4f76850d3 100644
--- a/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb
+++ b/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb
@@ -17,6 +17,8 @@  SRCREV = "2343fd6b5214b2ded2cdcf76de2bf60903bb90cd"
 
 S = "${WORKDIR}/git"
 
+EXTRA_OEMAKE = "PLATFORM=linux"
+
 do_configure[noexec] = "1"
 
 do_compile() {
@@ -24,7 +26,7 @@  do_compile() {
 }
 
 do_install() {
-    oe_runmake install DESTDIR=${D} PREFIX=${prefix}
+    oe_runmake install DESTDIR=${D} PREFIX=${prefix} LIBDIR=${libdir}
 }
 
 BBCLASSEXTEND = "native nativesdk"