[meta-oe] libiio: point PYPA_WHEEL to custom location

Message ID 20220306063116.710-1-sam.van.den.berge@gmail.com
State New
Headers show
Series [meta-oe] libiio: point PYPA_WHEEL to custom location | expand

Commit Message

Sam Van Den Berge March 6, 2022, 6:31 a.m. UTC
From: Sam Van Den Berge <sam.van.den.berge@gmail.com>

This fixes the installation of the python bindings of libiio.

Signed-off-by: Sam Van Den Berge <sam.van.den.berge@gmail.com>
---
 meta-oe/recipes-support/libiio/libiio_git.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Khem Raj March 6, 2022, 7:29 a.m. UTC | #1
Thanks for fixing this

On Sat, Mar 5, 2022 at 10:31 PM Sam Van Den Berge
<sam.van.den.berge@gmail.com> wrote:
>
> From: Sam Van Den Berge <sam.van.den.berge@gmail.com>
>
> This fixes the installation of the python bindings of libiio.
>
> Signed-off-by: Sam Van Den Berge <sam.van.den.berge@gmail.com>
> ---
>  meta-oe/recipes-support/libiio/libiio_git.bb | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
> index f33fc0c1c..19753a13b 100644
> --- a/meta-oe/recipes-support/libiio/libiio_git.bb
> +++ b/meta-oe/recipes-support/libiio/libiio_git.bb
> @@ -15,6 +15,9 @@ UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
>  S = "${WORKDIR}/git"
>
>  SETUPTOOLS_SETUP_PATH ?= "${B}/bindings/python/"
> +PIP_INSTALL_PACKAGE = "libiio"
> +PIP_INSTALL_DIST_PATH = "${B}/bindings/python/dist/"
> +PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-0.21-*.whl"

perhaps we do not need to set PYPA_WHEEL perhaps. I am also wondering
why its not failing in
oe world builds. Can you check it again with latest master-next of
both core and meta-oe


>
>  DEPENDS = " \
>      flex-native bison-native libaio \
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#95810): https://lists.openembedded.org/g/openembedded-devel/message/95810
> Mute This Topic: https://lists.openembedded.org/mt/89585637/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Sam Van Den Berge March 8, 2022, 11:38 a.m. UTC | #2
On Sat, Mar 05, 2022 at 11:29:42PM -0800, Khem Raj wrote:
> Thanks for fixing this
> 
> On Sat, Mar 5, 2022 at 10:31 PM Sam Van Den Berge
> <sam.van.den.berge@gmail.com> wrote:
> >
> > From: Sam Van Den Berge <sam.van.den.berge@gmail.com>
> >
> > This fixes the installation of the python bindings of libiio.
> >
> > Signed-off-by: Sam Van Den Berge <sam.van.den.berge@gmail.com>
> > ---
> >  meta-oe/recipes-support/libiio/libiio_git.bb | 3 +++
> >  1 file changed, 3 insertions(+)
> >
> > diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
> > index f33fc0c1c..19753a13b 100644
> > --- a/meta-oe/recipes-support/libiio/libiio_git.bb
> > +++ b/meta-oe/recipes-support/libiio/libiio_git.bb
> > @@ -15,6 +15,9 @@ UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
> >  S = "${WORKDIR}/git"
> >
> >  SETUPTOOLS_SETUP_PATH ?= "${B}/bindings/python/"
> > +PIP_INSTALL_PACKAGE = "libiio"
> > +PIP_INSTALL_DIST_PATH = "${B}/bindings/python/dist/"
> > +PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-0.21-*.whl"
> 
> perhaps we do not need to set PYPA_WHEEL perhaps. I am also wondering
> why its not failing in
> oe world builds. Can you check it again with latest master-next of
> both core and meta-oe
> 

Thanks for the hint.

Tried today with latest master and it worked without my patch. I guess commit
6f2d85a7b7d9 in oe-core fixes some things so this patch can be dropped.

> >
> >  DEPENDS = " \
> >      flex-native bison-native libaio \
> > --
> > 2.25.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#95810): https://lists.openembedded.org/g/openembedded-devel/message/95810
> > Mute This Topic: https://lists.openembedded.org/mt/89585637/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Khem Raj March 8, 2022, 4:03 p.m. UTC | #3
Ok, thanks.

On Tue, Mar 8, 2022 at 3:38 AM Sam Van Den Berge
<sam.van.den.berge@gmail.com> wrote:
>
> On Sat, Mar 05, 2022 at 11:29:42PM -0800, Khem Raj wrote:
> > Thanks for fixing this
> >
> > On Sat, Mar 5, 2022 at 10:31 PM Sam Van Den Berge
> > <sam.van.den.berge@gmail.com> wrote:
> > >
> > > From: Sam Van Den Berge <sam.van.den.berge@gmail.com>
> > >
> > > This fixes the installation of the python bindings of libiio.
> > >
> > > Signed-off-by: Sam Van Den Berge <sam.van.den.berge@gmail.com>
> > > ---
> > >  meta-oe/recipes-support/libiio/libiio_git.bb | 3 +++
> > >  1 file changed, 3 insertions(+)
> > >
> > > diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
> > > index f33fc0c1c..19753a13b 100644
> > > --- a/meta-oe/recipes-support/libiio/libiio_git.bb
> > > +++ b/meta-oe/recipes-support/libiio/libiio_git.bb
> > > @@ -15,6 +15,9 @@ UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
> > >  S = "${WORKDIR}/git"
> > >
> > >  SETUPTOOLS_SETUP_PATH ?= "${B}/bindings/python/"
> > > +PIP_INSTALL_PACKAGE = "libiio"
> > > +PIP_INSTALL_DIST_PATH = "${B}/bindings/python/dist/"
> > > +PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-0.21-*.whl"
> >
> > perhaps we do not need to set PYPA_WHEEL perhaps. I am also wondering
> > why its not failing in
> > oe world builds. Can you check it again with latest master-next of
> > both core and meta-oe
> >
>
> Thanks for the hint.
>
> Tried today with latest master and it worked without my patch. I guess commit
> 6f2d85a7b7d9 in oe-core fixes some things so this patch can be dropped.
>
> > >
> > >  DEPENDS = " \
> > >      flex-native bison-native libaio \
> > > --
> > > 2.25.1
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#95810): https://lists.openembedded.org/g/openembedded-devel/message/95810
> > > Mute This Topic: https://lists.openembedded.org/mt/89585637/1997914
> > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >

Patch

diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
index f33fc0c1c..19753a13b 100644
--- a/meta-oe/recipes-support/libiio/libiio_git.bb
+++ b/meta-oe/recipes-support/libiio/libiio_git.bb
@@ -15,6 +15,9 @@  UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
 S = "${WORKDIR}/git"
 
 SETUPTOOLS_SETUP_PATH ?= "${B}/bindings/python/"
+PIP_INSTALL_PACKAGE = "libiio"
+PIP_INSTALL_DIST_PATH = "${B}/bindings/python/dist/"
+PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-0.21-*.whl"
 
 DEPENDS = " \
     flex-native bison-native libaio \