[meta-oe,master] libtinyxml2: fix packaging of test files

Message ID 20220305213515.5572-1-nisha.m.parrakat@bmw.de
State New
Headers show
Series [meta-oe,master] libtinyxml2: fix packaging of test files | expand

Commit Message

Nisha Parrakat March 5, 2022, 9:35 p.m. UTC
The xml files inside the resources are to be used for the
run of test named xmltest
they were not getting copied from the source directory to the directory
where xmltest was installed

fixes the below error when code built with cmake
./xmltest
Error opening test file 'dream.xml'.
Is your working directory the same as where
the xmltest.cpp and dream.xml file are?

Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)

Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
---
 ...y_resources_with_tests_in_CMakelists.patch | 30 +++++++++++++++++++
 .../libtinyxml2/libtinyxml2_9.0.0.bb          |  4 ++-
 2 files changed, 33 insertions(+), 1 deletion(-)
 create mode 100644 meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch

Comments

akuster808 March 5, 2022, 9:49 p.m. UTC | #1
Nisha,

thanks for the patch. feedback in-lined below.

On 3/5/22 13:35, Nisha Parrakat wrote:
> The xml files inside the resources are to be used for the
> run of test named xmltest
> they were not getting copied from the source directory to the directory
> where xmltest was installed
>
> fixes the below error when code built with cmake
> ./xmltest
> Error opening test file 'dream.xml'.
> Is your working directory the same as where
> the xmltest.cpp and dream.xml file are?
>
> Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)

This seems to confuse folks a lot. The "Upstream-Status" needs to be in 
the patch it self, not the commit message.

see below.

>
> Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
> ---
>   ...y_resources_with_tests_in_CMakelists.patch | 30 +++++++++++++++++++
>   .../libtinyxml2/libtinyxml2_9.0.0.bb          |  4 ++-
>   2 files changed, 33 insertions(+), 1 deletion(-)
>   create mode 100644 meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
>
> diff --git a/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
> new file mode 100644
> index 000000000..09245ad36
> --- /dev/null
> +++ b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
> @@ -0,0 +1,30 @@
> +The xml files inside the resources are to be used for the
> +run of test named xmltest
> +they were not getting copied from the source directory to the directory
> +where xmltest was installed
> +
> +fixes the below error when code built with cmake
> +./xmltest
> +Error opening test file 'dream.xml'.
> +Is your working directory the same as where
> +the xmltest.cpp and dream.xml file are?

Here:

Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)


-armin
> +
> +Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
> +Signed-off-by: Nisha Parrakat <nishaparrakat@gmail.com>
> +
> +Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)
> +--- a/CMakeLists.txt	2022-03-05 22:00:33.361601287 +0100
> ++++ b/CMakelist.txt	2022-03-05 22:05:19.953940006 +0100
> +@@ -51,6 +51,12 @@
> +         WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
> +     )
> +
> ++    # Copy test resources and create test output directory
> ++    add_custom_command(TARGET xmltest POST_BUILD
> ++	COMMAND ${CMAKE_COMMAND} -E copy_directory ${CMAKE_CURRENT_SOURCE_DIR}/resources $<TARGET_FILE_DIR:xmltest>/resources
> ++	COMMAND ${CMAKE_COMMAND} -E make_directory $<TARGET_FILE_DIR:xmltest>/resources/out
> ++	COMMENT "Configuring xmltest resources directory: ${CMAKE_CURRENT_BINARY_DIR}/resources"
> ++    )
> +     set_tests_properties(xmltest PROPERTIES PASS_REGULAR_EXPRESSION ", Fail 0")
> + endif ()
> +
> diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
> index 7f205987f..06410ab6e 100644
> --- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
> +++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
> @@ -4,7 +4,9 @@ SECTION = "libs"
>   LICENSE = "Zlib"
>   LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
>   
> -SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https"
> +SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
> +           file://copy_resources_with_tests_in_CMakelists.patch \
> +          "
>   
>   SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82"
>   
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#95806): https://lists.openembedded.org/g/openembedded-devel/message/95806
> Mute This Topic: https://lists.openembedded.org/mt/89522514/3616698
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [akuster808@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj March 6, 2022, 3:55 a.m. UTC | #2
this patch does not apply again

https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/1488

On Sat, Mar 5, 2022 at 1:49 PM akuster808 <akuster808@gmail.com> wrote:
>
> Nisha,
>
> thanks for the patch. feedback in-lined below.
>
> On 3/5/22 13:35, Nisha Parrakat wrote:
> > The xml files inside the resources are to be used for the
> > run of test named xmltest
> > they were not getting copied from the source directory to the directory
> > where xmltest was installed
> >
> > fixes the below error when code built with cmake
> > ./xmltest
> > Error opening test file 'dream.xml'.
> > Is your working directory the same as where
> > the xmltest.cpp and dream.xml file are?
> >
> > Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)
>
> This seems to confuse folks a lot. The "Upstream-Status" needs to be in
> the patch it self, not the commit message.
>
> see below.
>
> >
> > Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
> > ---
> >   ...y_resources_with_tests_in_CMakelists.patch | 30 +++++++++++++++++++
> >   .../libtinyxml2/libtinyxml2_9.0.0.bb          |  4 ++-
> >   2 files changed, 33 insertions(+), 1 deletion(-)
> >   create mode 100644 meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
> >
> > diff --git a/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
> > new file mode 100644
> > index 000000000..09245ad36
> > --- /dev/null
> > +++ b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
> > @@ -0,0 +1,30 @@
> > +The xml files inside the resources are to be used for the
> > +run of test named xmltest
> > +they were not getting copied from the source directory to the directory
> > +where xmltest was installed
> > +
> > +fixes the below error when code built with cmake
> > +./xmltest
> > +Error opening test file 'dream.xml'.
> > +Is your working directory the same as where
> > +the xmltest.cpp and dream.xml file are?
>
> Here:
>
> Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)
>
>
> -armin
> > +
> > +Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
> > +Signed-off-by: Nisha Parrakat <nishaparrakat@gmail.com>
> > +
> > +Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)
> > +--- a/CMakeLists.txt 2022-03-05 22:00:33.361601287 +0100
> > ++++ b/CMakelist.txt  2022-03-05 22:05:19.953940006 +0100
> > +@@ -51,6 +51,12 @@
> > +         WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
> > +     )
> > +
> > ++    # Copy test resources and create test output directory
> > ++    add_custom_command(TARGET xmltest POST_BUILD
> > ++    COMMAND ${CMAKE_COMMAND} -E copy_directory ${CMAKE_CURRENT_SOURCE_DIR}/resources $<TARGET_FILE_DIR:xmltest>/resources
> > ++    COMMAND ${CMAKE_COMMAND} -E make_directory $<TARGET_FILE_DIR:xmltest>/resources/out
> > ++    COMMENT "Configuring xmltest resources directory: ${CMAKE_CURRENT_BINARY_DIR}/resources"
> > ++    )
> > +     set_tests_properties(xmltest PROPERTIES PASS_REGULAR_EXPRESSION ", Fail 0")
> > + endif ()
> > +
> > diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
> > index 7f205987f..06410ab6e 100644
> > --- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
> > +++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
> > @@ -4,7 +4,9 @@ SECTION = "libs"
> >   LICENSE = "Zlib"
> >   LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
> >
> > -SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https"
> > +SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
> > +           file://copy_resources_with_tests_in_CMakelists.patch \
> > +          "
> >
> >   SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82"
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#95806): https://lists.openembedded.org/g/openembedded-devel/message/95806
> > Mute This Topic: https://lists.openembedded.org/mt/89522514/3616698
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [akuster808@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
Nisha Parrakat March 6, 2022, 7:52 p.m. UTC | #3
HI Khem,

unable to understand why it doesn't apply.

it seems to build locally at my system.

The file that i patch that is CMakeLists.txt is of format dos. Is that 
creating a problem ?


regards

Nisha P



On 06.03.22 04:55, Khem Raj wrote:
> this patch does not apply again
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/1488
>
> On Sat, Mar 5, 2022 at 1:49 PM akuster808 <akuster808@gmail.com> wrote:
>> Nisha,
>>
>> thanks for the patch. feedback in-lined below.
>>
>> On 3/5/22 13:35, Nisha Parrakat wrote:
>>> The xml files inside the resources are to be used for the
>>> run of test named xmltest
>>> they were not getting copied from the source directory to the directory
>>> where xmltest was installed
>>>
>>> fixes the below error when code built with cmake
>>> ./xmltest
>>> Error opening test file 'dream.xml'.
>>> Is your working directory the same as where
>>> the xmltest.cpp and dream.xml file are?
>>>
>>> Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)
>> This seems to confuse folks a lot. The "Upstream-Status" needs to be in
>> the patch it self, not the commit message.
>>
>> see below.
>>
>>> Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
>>> ---
>>>    ...y_resources_with_tests_in_CMakelists.patch | 30 +++++++++++++++++++
>>>    .../libtinyxml2/libtinyxml2_9.0.0.bb          |  4 ++-
>>>    2 files changed, 33 insertions(+), 1 deletion(-)
>>>    create mode 100644 meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
>>>
>>> diff --git a/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
>>> new file mode 100644
>>> index 000000000..09245ad36
>>> --- /dev/null
>>> +++ b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
>>> @@ -0,0 +1,30 @@
>>> +The xml files inside the resources are to be used for the
>>> +run of test named xmltest
>>> +they were not getting copied from the source directory to the directory
>>> +where xmltest was installed
>>> +
>>> +fixes the below error when code built with cmake
>>> +./xmltest
>>> +Error opening test file 'dream.xml'.
>>> +Is your working directory the same as where
>>> +the xmltest.cpp and dream.xml file are?
>> Here:
>>
>> Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)
>>
>>
>> -armin
>>> +
>>> +Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
>>> +Signed-off-by: Nisha Parrakat <nishaparrakat@gmail.com>
>>> +
>>> +Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)
>>> +--- a/CMakeLists.txt 2022-03-05 22:00:33.361601287 +0100
>>> ++++ b/CMakelist.txt  2022-03-05 22:05:19.953940006 +0100
>>> +@@ -51,6 +51,12 @@
>>> +         WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
>>> +     )
>>> +
>>> ++    # Copy test resources and create test output directory
>>> ++    add_custom_command(TARGET xmltest POST_BUILD
>>> ++    COMMAND ${CMAKE_COMMAND} -E copy_directory ${CMAKE_CURRENT_SOURCE_DIR}/resources $<TARGET_FILE_DIR:xmltest>/resources
>>> ++    COMMAND ${CMAKE_COMMAND} -E make_directory $<TARGET_FILE_DIR:xmltest>/resources/out
>>> ++    COMMENT "Configuring xmltest resources directory: ${CMAKE_CURRENT_BINARY_DIR}/resources"
>>> ++    )
>>> +     set_tests_properties(xmltest PROPERTIES PASS_REGULAR_EXPRESSION ", Fail 0")
>>> + endif ()
>>> +
>>> diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
>>> index 7f205987f..06410ab6e 100644
>>> --- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
>>> +++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
>>> @@ -4,7 +4,9 @@ SECTION = "libs"
>>>    LICENSE = "Zlib"
>>>    LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
>>>
>>> -SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https"
>>> +SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
>>> +           file://copy_resources_with_tests_in_CMakelists.patch \
>>> +          "
>>>
>>>    SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82"
>>>
>>>
>>> -=-=-=-=-=-=-=-=-=-=-=-
>>> Links: You receive all messages sent to this group.
>>> View/Reply Online (#95806): https://lists.openembedded.org/g/openembedded-devel/message/95806
>>> Mute This Topic: https://lists.openembedded.org/mt/89522514/3616698
>>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [akuster808@gmail.com]
>>> -=-=-=-=-=-=-=-=-=-=-=-
>>>
Nisha Parrakat March 7, 2022, 11:57 a.m. UTC | #4
HI Khem,

Could you please check the attached format-patch file attached with this
email to see if it works ?


regards

Nisha P




On 06.03.22 04:55, Khem Raj wrote:

this patch does not apply again
https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/1488

On Sat, Mar 5, 2022 at 1:49 PM akuster808 <akuster808@gmail.com>
<akuster808@gmail.com> wrote:

Nisha,

thanks for the patch. feedback in-lined below.

On 3/5/22 13:35, Nisha Parrakat wrote:

The xml files inside the resources are to be used for the
run of test named xmltest
they were not getting copied from the source directory to the directory
where xmltest was installed

fixes the below error when code built with cmake
./xmltest
Error opening test file 'dream.xml'.
Is your working directory the same as where
the xmltest.cpp and dream.xml file are?

Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)

This seems to confuse folks a lot. The "Upstream-Status" needs to be in
the patch it self, not the commit message.

see below.


Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
<nisha.m.parrakat@bmw.de>
---
  ...y_resources_with_tests_in_CMakelists.patch | 30 +++++++++++++++++++
  .../libtinyxml2/libtinyxml2_9.0.0.bb          |  4 ++-
  2 files changed, 33 insertions(+), 1 deletion(-)
  create mode 100644
meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch

diff --git a/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
new file mode 100644
index 000000000..09245ad36
--- /dev/null
+++ b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
@@ -0,0 +1,30 @@
+The xml files inside the resources are to be used for the
+run of test named xmltest
+they were not getting copied from the source directory to the directory
+where xmltest was installed
+
+fixes the below error when code built with cmake
+./xmltest
+Error opening test file 'dream.xml'.
+Is your working directory the same as where
+the xmltest.cpp and dream.xml file are?

Here:

Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)


-armin

+
+Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
<nisha.m.parrakat@bmw.de>
+Signed-off-by: Nisha Parrakat <nishaparrakat@gmail.com>
<nishaparrakat@gmail.com>
+
+Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)
+--- a/CMakeLists.txt 2022-03-05 22:00:33.361601287 +0100
++++ b/CMakelist.txt  2022-03-05 22:05:19.953940006 +0100
+@@ -51,6 +51,12 @@
+         WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
+     )
+
++    # Copy test resources and create test output directory
++    add_custom_command(TARGET xmltest POST_BUILD
++    COMMAND ${CMAKE_COMMAND} -E copy_directory
${CMAKE_CURRENT_SOURCE_DIR}/resources
$<TARGET_FILE_DIR:xmltest>/resources
++    COMMAND ${CMAKE_COMMAND} -E make_directory
$<TARGET_FILE_DIR:xmltest>/resources/out
++    COMMENT "Configuring xmltest resources directory:
${CMAKE_CURRENT_BINARY_DIR}/resources"
++    )
+     set_tests_properties(xmltest PROPERTIES PASS_REGULAR_EXPRESSION
", Fail 0")
+ endif ()
+
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
index 7f205987f..06410ab6e 100644
--- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
+++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
@@ -4,7 +4,9 @@ SECTION = "libs"
  LICENSE = "Zlib"
  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"

-SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https"
+SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https
\
+           file://copy_resources_with_tests_in_CMakelists.patch \
+          "

  SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82"


-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#95806):
https://lists.openembedded.org/g/openembedded-devel/message/95806
Mute This Topic: https://lists.openembedded.org/mt/89522514/3616698
Group Owner: openembedded-devel+owner@lists.openembedded.org
Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub
[akuster808@gmail.com]
-=-=-=-=-=-=-=-=-=-=-=-

Patch

diff --git a/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
new file mode 100644
index 000000000..09245ad36
--- /dev/null
+++ b/meta-oe/recipes-support/libtinyxml2/files/copy_resources_with_tests_in_CMakelists.patch
@@ -0,0 +1,30 @@ 
+The xml files inside the resources are to be used for the
+run of test named xmltest
+they were not getting copied from the source directory to the directory
+where xmltest was installed
+
+fixes the below error when code built with cmake
+./xmltest
+Error opening test file 'dream.xml'.
+Is your working directory the same as where
+the xmltest.cpp and dream.xml file are?
+
+Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
+Signed-off-by: Nisha Parrakat <nishaparrakat@gmail.com>
+
+Upstream-Status: Submitted (https://github.com/leethomason/tinyxml2/pull/902)
+--- a/CMakeLists.txt	2022-03-05 22:00:33.361601287 +0100
++++ b/CMakelist.txt	2022-03-05 22:05:19.953940006 +0100
+@@ -51,6 +51,12 @@
+         WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
+     )
+ 
++    # Copy test resources and create test output directory
++    add_custom_command(TARGET xmltest POST_BUILD
++	COMMAND ${CMAKE_COMMAND} -E copy_directory ${CMAKE_CURRENT_SOURCE_DIR}/resources $<TARGET_FILE_DIR:xmltest>/resources
++	COMMAND ${CMAKE_COMMAND} -E make_directory $<TARGET_FILE_DIR:xmltest>/resources/out
++	COMMENT "Configuring xmltest resources directory: ${CMAKE_CURRENT_BINARY_DIR}/resources"
++    )
+     set_tests_properties(xmltest PROPERTIES PASS_REGULAR_EXPRESSION ", Fail 0")
+ endif ()
+ 
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
index 7f205987f..06410ab6e 100644
--- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
+++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
@@ -4,7 +4,9 @@  SECTION = "libs"
 LICENSE = "Zlib"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
 
-SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https"
+SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
+           file://copy_resources_with_tests_in_CMakelists.patch \
+          "
 
 SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82"