[meta-multimedia] pipewire: fix build error when pipewire-jack is used

Message ID 20220211153626.1930814-1-peter@berginkonsult.se
State New
Headers show
Series [meta-multimedia] pipewire: fix build error when pipewire-jack is used | expand

Commit Message

Peter Bergin Feb. 11, 2022, 3:36 p.m. UTC
If PACKAGECONFIG contains pipewire-jack the following error was seen:

    ERROR: pipewire-0.3.45-r0 do_package: QA Issue: pipewire: Files/directories were installed but not shipped in any package:
      /usr/bin/pw-jack
      /usr/share/pipewire/minimal.conf
    Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
    pipewire: 2 installed and not shipped files. [installed-vs-shipped]

File /usr/bin/pw-jack is added to pipewire-jack package.

The removal of minimal.conf was conditional to not configuring 'pipewire-jack'.
Can not see any reason to make it conditional on that specific option and make
it always removed to avoid packaging error.

Errors introduced in 687483235b5542401245711cb610ec327b33c403

Signed-off-by: Peter Bergin <peter@berginkonsult.se>
---
 .../recipes-multimedia/pipewire/pipewire_0.3.45.bb        | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Patch

diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.45.bb b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.45.bb
index 31798e47c..6ba312484 100644
--- a/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.45.bb
+++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.45.bb
@@ -114,12 +114,13 @@  remove_unused_installed_files() {
     # jack.conf is used by pipewire-jack (not the JACK SPA plugin).
     # Remove it if pipewire-jack is not built to avoid creating the
     # pipewire-jack package.
-    # minimal.conf is an example of how to minimally configure the
-    # daemon and is not meant to be used for production.
     if ${@bb.utils.contains('PACKAGECONFIG', 'pipewire-jack', 'false', 'true', d)}; then
         rm -f "${D}${datadir}/pipewire/jack.conf"
-        rm -f "${D}${datadir}/pipewire/minimal.conf"
     fi
+
+    # minimal.conf is an example of how to minimally configure the
+    # daemon and is not meant to be used for production.
+    rm -f "${D}${datadir}/pipewire/minimal.conf"
 }
 
 do_install[postfuncs] += "remove_unused_installed_files"
@@ -284,6 +285,7 @@  FILES:${PN}-alsa = "\
 # JACK drop-in libraries to redirect audio to pipewire.
 CONFFILES:${PN}-jack = "${datadir}/pipewire/jack.conf"
 FILES:${PN}-jack = "\
+    ${bindir}/pw-jack \
     ${datadir}/pipewire/jack.conf \
     ${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so.* \
 "