[meta-gnome] gimp: Disable vector icons on x86 with clang

Message ID 20220208061059.762064-1-raj.khem@gmail.com
State New
Headers show
Series [meta-gnome] gimp: Disable vector icons on x86 with clang | expand

Commit Message

Khem Raj Feb. 8, 2022, 6:10 a.m. UTC
It workarounds qemu crashes seen when building with clang

e.g.
| make[3]: *** [Makefile:2397: 24/gimp-controller.svg] Segmentation fault
| make[3]: *** Waiting for unfinished jobs....
| make[3]: *** [Makefile:2397: 24/gimp-color-space-perceptual.svg] Segmentation fault
| make[3]: *** [Makefile:2397: 24/gimp-controller-keyboard.svg] Segmentation fault
| make[3]: *** [Makefile:2397: 24/gimp-colormap.svg] Segmentation fault

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-gnome/recipes-gimp/gimp/gimp_2.10.30.bb | 1 +
 1 file changed, 1 insertion(+)

Patch

diff --git a/meta-gnome/recipes-gimp/gimp/gimp_2.10.30.bb b/meta-gnome/recipes-gimp/gimp/gimp_2.10.30.bb
index a74e240ff6..68a7a923e2 100644
--- a/meta-gnome/recipes-gimp/gimp/gimp_2.10.30.bb
+++ b/meta-gnome/recipes-gimp/gimp/gimp_2.10.30.bb
@@ -53,6 +53,7 @@  EXTRA_OECONF = "--disable-python \
 
 EXTRA_OECONF:append:toolchain-clang:riscv32 = " --disable-vector-icons"
 EXTRA_OECONF:append:toolchain-clang:mips = " --disable-vector-icons"
+EXTRA_OECONF:append:toolchain-clang:x86 = " --disable-vector-icons"
 
 do_configure:append() {
     find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g