[meta-python,2/2] python3-coverage: Upgrade 6.2 -> 6.3

Message ID 20220131113942.2417929-2-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/2] python3-ansi2html: Upgrade 1.6.0 -> 1.7.0 | expand

Commit Message

Leon Anavi Jan. 31, 2022, 11:39 a.m. UTC
Upgrade to release 6.3:

- Added the lcov command to generate reports in LCOV format.
- the coverage data file can now be specified on the command line
  with the --data-file option in any command that reads or writes
  data. This is in addition to the existing COVERAGE_FILE
  environment variable.
- coverage measurement data will now be written when a SIGTERM
  signal is received by the process. This includes
  Process.terminate, and other ways to terminate a process.
  Currently this is only on Linux and Mac; Windows is not supported.
- Dropped support for Python 3.6, which reached end-of-life on
  2021-12-23.
- Updated Python 3.11 support to 3.11.0a4.
- Fix: the coverage data file is now created in a more robust way,
  to avoid problems when multiple processes are trying to write
  data at once.
- Fix: a .gitignore file will only be written into the HTML report
  output directory if the directory is empty. This should prevent
  certain unfortunate accidents of writing the file where it is
  not wanted.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-coverage_6.2.bb => python3-coverage_6.3.bb}    | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-coverage_6.2.bb => python3-coverage_6.3.bb} (60%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-coverage_6.2.bb b/meta-python/recipes-devtools/python/python3-coverage_6.3.bb
similarity index 60%
rename from meta-python/recipes-devtools/python/python3-coverage_6.2.bb
rename to meta-python/recipes-devtools/python/python3-coverage_6.3.bb
index 6e080b00c..0ed90281f 100644
--- a/meta-python/recipes-devtools/python/python3-coverage_6.2.bb
+++ b/meta-python/recipes-devtools/python/python3-coverage_6.3.bb
@@ -3,10 +3,14 @@  HOMEPAGE = "https://coverage.readthedocs.io"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
 
-SRC_URI[sha256sum] = "e2cad8093172b7d1595b4ad66f24270808658e11acf43a8f95b41276162eb5b8"
+SRC_URI[sha256sum] = "987a84ff98a309994ca77ed3cc4b92424f824278e48e4bf7d1bb79a63cfe2099"
 
 inherit pypi setuptools3
 
 RDEPENDS:${PN} += " \
 	${PYTHON_PN}-sqlite3 \
+	${PYTHON_PN}-core \
+	${PYTHON_PN}-pprint \
+	${PYTHON_PN}-json \
+	${PYTHON_PN}-xml \
 "