[meta-python,4/4] python3-redis: Upgrade 4.0.2 -> 4.1.1

Message ID 20220124151544.876177-4-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/4] python3-imageio: Upgrade 2.14.0 -> 2.14.1 | expand

Commit Message

Leon Anavi Jan. 24, 2022, 3:15 p.m. UTC
Upgrade to release 4.1.1:

- Add retries to connections in Sentinel Pools
- OCSP Stapling Support
- Define incr/decr as aliases of incrby/decrby
- FT.CREATE - support MAXTEXTFIELDS, TEMPORARY, NOHL, NOFREQS,
  SKIPINITIALSCAN

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/{python3-redis_4.0.2.bb => python3-redis_4.1.1.bb}  | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-redis_4.0.2.bb => python3-redis_4.1.1.bb} (76%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-redis_4.0.2.bb b/meta-python/recipes-devtools/python/python3-redis_4.1.1.bb
similarity index 76%
rename from meta-python/recipes-devtools/python/python3-redis_4.0.2.bb
rename to meta-python/recipes-devtools/python/python3-redis_4.1.1.bb
index f39a72c60..9af7383de 100644
--- a/meta-python/recipes-devtools/python/python3-redis_4.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-redis_4.1.1.bb
@@ -4,11 +4,12 @@  HOMEPAGE = "http://github.com/andymccurdy/redis-py"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=51d9ad56299ab60ba7be65a621004f27"
 
-SRC_URI[sha256sum] = "ccf692811f2c1fc7a92b466aa2599e4a6d2d73d5f736a2c70be600657c0da34a"
+SRC_URI[sha256sum] = "07420a3fbedd8e012c31d4fadac943fb81568946da202c5a5bc237774e5280a0"
 
 inherit pypi setuptools3
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-datetime \
     ${PYTHON_PN}-cryptography \
+    ${PYTHON_PN}-packaging \
 "