[meta-python,2/3] python3-pytest-helpers-namespace: Enable network during do_compile

Message ID 20220111202225.1526283-2-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/3] python3-matplotlib: Do not use setuptools_scm_git_archive | expand

Commit Message

Khem Raj Jan. 11, 2022, 8:22 p.m. UTC
This should actually be fixed in the package's build system to not
do the network access during compile task. Lets workaround it for now

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../python/python3-pytest-helpers-namespace_2021.4.29.bb        | 2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2021.4.29.bb b/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2021.4.29.bb
index c1f9f96ff4..141f12aef7 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2021.4.29.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2021.4.29.bb
@@ -8,6 +8,8 @@  SRC_URI[sha256sum] = "183524e3db4e2a1fea92e0ca3662a624ba44c9f3568da15679d7535ba6
 
 inherit pypi setuptools3
 
+do_compile[network] = "1"
+
 DEPENDS += "\
     ${PYTHON_PN}-wheel-native \
     ${PYTHON_PN}-pip-native \