[meta-python,3/5] python3-urllib3: Upgrade 1.26.7 -> 1.26.8

Message ID 20220110193815.103592-3-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/5] python3-google-api-core: Upgrade 2.2.0 -> 2.3.2 | expand

Commit Message

Leon Anavi Jan. 10, 2022, 7:38 p.m. UTC
Upgrade to release 1.26.8:

- Added extra message tourllib3.exceptions.ProxyError when urllib3
  detects that a proxy is configured to use HTTPS but the proxy
  itself appears to only use HTTP.
- Added a mention of the size of the connection pool when
  discarding a connection due to the pool being full.
- Added explicit support for Python 3.11.
- Deprecated the Retry.MAX_BACKOFF class property in favor of
  Retry.DEFAULT_MAX_BACKOFF to better match the rest of the default
  parameter names. Retry.MAX_BACKOFF is removed in v2.0.
- Changed location of the vendored ssl.match_hostname function from
  urllib3.packages.ssl_match_hostname to urllib3.util.ssl_match_hostname
  to ensure Python 3.10+ compatibility after being repackaged by
  downstream distributors.
- Fixed absolute imports, all imports are now relative.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-urllib3_1.26.7.bb => python3-urllib3_1.26.8.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-urllib3_1.26.7.bb => python3-urllib3_1.26.8.bb} (86%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-urllib3_1.26.7.bb b/meta-python/recipes-devtools/python/python3-urllib3_1.26.8.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-urllib3_1.26.7.bb
rename to meta-python/recipes-devtools/python/python3-urllib3_1.26.8.bb
index 72696749b..c2a51b914 100644
--- a/meta-python/recipes-devtools/python/python3-urllib3_1.26.7.bb
+++ b/meta-python/recipes-devtools/python/python3-urllib3_1.26.8.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/shazow/urllib3"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
 
-SRC_URI[sha256sum] = "4987c65554f7a2dbf30c18fd48778ef124af6fab771a377103da0585e2336ece"
+SRC_URI[sha256sum] = "0e7c33d9a63e7ddfcb86780aac87befc2fbddf46c58dbb487e0855f7ceec283c"
 
 inherit pypi setuptools3