[meta-python] python3-colorzero: add recipe for python colorzero

Message ID 20220110152627.57765-1-bhargavthriler@gmail.com
State New
Headers show
Series [meta-python] python3-colorzero: add recipe for python colorzero | expand

Commit Message

Bhargav Das Jan. 10, 2022, 3:26 p.m. UTC
colorzero is a color manipulation library for Python

Signed-off-by: Bhargav Das <bhargavthriler@gmail.com>
---
 .../python/python3-colorzero_2.0.bb              | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-colorzero_2.0.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-colorzero_2.0.bb b/meta-python/recipes-devtools/python/python3-colorzero_2.0.bb
new file mode 100644
index 000000000..1a331d13f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-colorzero_2.0.bb
@@ -0,0 +1,16 @@ 
+SUMMARY = "colorzero is a color manipulation library for Python"
+DESCRIPTION = "colorzero is a color manipulation library for Python \
+(yes, another one) which aims to be reasonably simple to use and \
+"pythonic" in nature."
+HOMEPAGE = " https://github.com/waveform80/colorzero "
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ae6c62710c0646f3c60d1ad812ea9bf9"
+
+RDEPENDS:${PN} = "python3-image"
+
+SRC_URI[sha256sum] = "e7d5a5c26cd0dc37b164ebefc609f388de24f8593b659191e12d85f8f9d5eb58"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "colorzero"