[meta-python,PATCHv2] python3-ujson: Upgrade 5.0.0 -> 5.1.0

Message ID 20220110122134.3754857-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,PATCHv2] python3-ujson: Upgrade 5.0.0 -> 5.1.0 | expand

Commit Message

Leon Anavi Jan. 10, 2022, 12:21 p.m. UTC
Upgrade to release 5.1.0:

- Strip debugging symbols from Linux binaries

Add a patch in setup.py to disable striping debugging symbols for
Linux to avoid already-stripped build errors.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...up.py-Do-not-strip-debugging-symbols.patch | 29 +++++++++++++++++++
 ...-ujson_5.0.0.bb => python3-ujson_5.1.0.bb} |  3 +-
 2 files changed, 31 insertions(+), 1 deletion(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch
 rename meta-python/recipes-devtools/python/{python3-ujson_5.0.0.bb => python3-ujson_5.1.0.bb} (83%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch
new file mode 100644
index 000000000..47da2b8cf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ujson/0001-setup.py-Do-not-strip-debugging-symbols.patch
@@ -0,0 +1,29 @@ 
+From aec3b64b0aaea0178b44ea65a204d76696e6a45e Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Mon, 10 Jan 2022 14:04:28 +0200
+Subject: [PATCH] setup.py: Do not strip debugging symbols
+
+Do not strip debugging symbols from Linux binaries to avoid
+bitbake build errors related to already-stripped.
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 453dc31..962c507 100644
+--- a/setup.py
++++ b/setup.py
+@@ -6,7 +6,7 @@ from setuptools import Extension, setup
+ dconv_source_files = glob("./deps/double-conversion/double-conversion/*.cc")
+ dconv_source_files.append("./lib/dconv_wrapper.cc")
+ 
+-strip_flags = ["-Wl,--strip-all"] if platform.system() == "Linux" else []
++strip_flags = []
+ 
+ module1 = Extension(
+     "ujson",
+-- 
+2.30.2
+
diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
similarity index 83%
rename from meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb
rename to meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
index fb1bcd761..6c1bf7e82 100644
--- a/meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
@@ -4,12 +4,13 @@  DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pu
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
 
-SRC_URI[sha256sum] = "3ff7242816b1d22c08c04c4c6db0f6ba7c16cd624ce38534c1025defa011e50e"
+SRC_URI[sha256sum] = "a88944d2f99db71a3ca0c63d81f37e55b660edde0b07216fb65a3e46403ef004"
 
 inherit pypi ptest setuptools3
 
 SRC_URI += " \
     file://run-ptest \
+    file://0001-setup.py-Do-not-strip-debugging-symbols.patch \
 "
 
 DEPENDS += "${PYTHON_PN}-setuptools-scm-native"