[meta-python,1/5] python3-psutil: Upgrade 5.8.0 -> 5.9.0

Message ID 20220107174730.3326962-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/5] python3-psutil: Upgrade 5.8.0 -> 5.9.0 | expand

Commit Message

Leon Anavi Jan. 7, 2022, 5:47 p.m. UTC
Upgrade to release 5.9.0:

- [Linux]: cpu_freq() is slow on systems with many CPUs. Read
  current frequency values for all CPUs from /proc/cpuinfo instead
  of opening many files in /sys fs. (patch by marxin)
- NoSuchProcess message now specifies if the PID has been reused.
- error classes (NoSuchProcess, AccessDenied, etc.) now have a
  better formatted and separated __repr__ and __str__
  implementations.
- [BSD]: add support for MidnightBSD.
- [Linux]: disk_partitions(): convert /dev/root device (an alias
  used on some Linux distros) to real root device path.
- PSUTIL_DEBUG mode now prints file name and line number of the
  debug messages coming from C extension modules.
- rewrite HISTORY.rst to use hyperlinks pointing to psutil API doc.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-psutil_5.8.0.bb => python3-psutil_5.9.0.bb}      | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-psutil_5.8.0.bb => python3-psutil_5.9.0.bb} (78%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb b/meta-python/recipes-devtools/python/python3-psutil_5.9.0.bb
similarity index 78%
rename from meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb
rename to meta-python/recipes-devtools/python/python3-psutil_5.9.0.bb
index 7186d3c97..cf3e0b39c 100644
--- a/meta-python/recipes-devtools/python/python3-psutil_5.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-psutil_5.9.0.bb
@@ -2,7 +2,7 @@  SUMMARY = "A cross-platform process and system utilities module for Python"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
 
-SRC_URI[sha256sum] = "0c9ccb99ab76025f2f0bbecf341d4656e9c1351db8cc8a03ccd62e318ab4b5c6"
+SRC_URI[sha256sum] = "869842dbd66bb80c3217158e629d6fceaecc3a3166d3d1faee515b05dd26ca25"
 
 inherit pypi setuptools3
 
@@ -19,6 +19,8 @@  RDEPENDS:${PN} += " \
     ${PYTHON_PN}-threading \
     ${PYTHON_PN}-xml \
     ${PYTHON_PN}-netclient \
+    ${PYTHON_PN}-ctypes \
+    ${PYTHON_PN}-resource \
 "
 
 BBCLASSEXTEND = "native nativesdk"