[meta-networking] mdio-tools: add recipes

Message ID 20220107150722.2221609-1-enguerrand.de-ribaucourt@savoirfairelinux.com
State New
Headers show
Series [meta-networking] mdio-tools: add recipes | expand

Commit Message

Enguerrand de Ribaucourt Jan. 7, 2022, 3:07 p.m. UTC
Self-description from the README: mdio-tools is a low-level debug tool
for communicating with devices attached to an MDIO bus.

Signed-off-by: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>
---
 .../mdio-tools/mdio-netlink_1.0.1.bb                | 13 +++++++++++++
 .../recipes-devtools/mdio-tools/mdio-tools_1.0.1.bb |  9 +++++++++
 .../mdio-tools/mdio-tools_1.0.1.inc                 |  8 ++++++++
 3 files changed, 30 insertions(+)
 create mode 100644 meta-networking/recipes-devtools/mdio-tools/mdio-netlink_1.0.1.bb
 create mode 100644 meta-networking/recipes-devtools/mdio-tools/mdio-tools_1.0.1.bb
 create mode 100644 meta-networking/recipes-devtools/mdio-tools/mdio-tools_1.0.1.inc

Patch

diff --git a/meta-networking/recipes-devtools/mdio-tools/mdio-netlink_1.0.1.bb b/meta-networking/recipes-devtools/mdio-tools/mdio-netlink_1.0.1.bb
new file mode 100644
index 000000000..9b6316141
--- /dev/null
+++ b/meta-networking/recipes-devtools/mdio-tools/mdio-netlink_1.0.1.bb
@@ -0,0 +1,13 @@ 
+require mdio-tools_1.0.1.inc
+
+DEPENDS += "virtual/kernel libmnl"
+# This module requires Linux 5.6 higher
+
+S = "${WORKDIR}/git/kernel"
+
+inherit module
+
+EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR}"
+MODULES_INSTALL_TARGET = "install"
+
+RPROVIDES:${PN} += "kernel-module-mdio-netlink"
diff --git a/meta-networking/recipes-devtools/mdio-tools/mdio-tools_1.0.1.bb b/meta-networking/recipes-devtools/mdio-tools/mdio-tools_1.0.1.bb
new file mode 100644
index 000000000..6f8a986b8
--- /dev/null
+++ b/meta-networking/recipes-devtools/mdio-tools/mdio-tools_1.0.1.bb
@@ -0,0 +1,9 @@ 
+require mdio-tools_1.0.1.inc
+
+DEPENDS += "libmnl"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools
+
+RDEPENDS:${PN} = "kernel-module-mdio-netlink"
diff --git a/meta-networking/recipes-devtools/mdio-tools/mdio-tools_1.0.1.inc b/meta-networking/recipes-devtools/mdio-tools/mdio-tools_1.0.1.inc
new file mode 100644
index 000000000..bba8960d8
--- /dev/null
+++ b/meta-networking/recipes-devtools/mdio-tools/mdio-tools_1.0.1.inc
@@ -0,0 +1,8 @@ 
+DESCRIPTION = "A low-level debug tool for communicating with devices attached to an MDIO bus"
+SECTION = "networking"
+HOMEPAGE = "https://github.com/wkz/mdio-tools"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/wkz/mdio-tools.git;protocol=https;branch=master"
+SRCREV = "b40809dd59aa199d8afc307e228b55eeae06b17e"