[meta-oe] php: avoid textrel QA Issue warning

Message ID 20220107080821.16187-1-mingli.yu@windriver.com
State New
Headers show
Series [meta-oe] php: avoid textrel QA Issue warning | expand

Commit Message

Yu, Mingli Jan. 7, 2022, 8:08 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

Fixes:
WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php: ELF binary /usr/libexec/apache2/modules/libphp.so has relocations in .text [textrel]
WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php-opcache: ELF binary /usr/lib/php8/extensions/no-debug-zts-20200930/opcache.so has relocations in .text [textrel]

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta-oe/recipes-devtools/php/php_8.1.0.bb | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Khem Raj Jan. 7, 2022, 6:48 p.m. UTC | #1
On 1/7/22 12:08 AM, Yu, Mingli wrote:
> From: Mingli Yu <mingli.yu@windriver.com>
> 
> Fixes:
> WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php: ELF binary /usr/libexec/apache2/modules/libphp.so has relocations in .text [textrel]
> WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php-opcache: ELF binary /usr/lib/php8/extensions/no-debug-zts-20200930/opcache.so has relocations in .text [textrel]
> 
> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
> ---
>   meta-oe/recipes-devtools/php/php_8.1.0.bb | 5 +++++
>   1 file changed, 5 insertions(+)
> 
> diff --git a/meta-oe/recipes-devtools/php/php_8.1.0.bb b/meta-oe/recipes-devtools/php/php_8.1.0.bb
> index 593eb3955..fd4a78786 100644
> --- a/meta-oe/recipes-devtools/php/php_8.1.0.bb
> +++ b/meta-oe/recipes-devtools/php/php_8.1.0.bb
> @@ -217,6 +217,11 @@ ALLOW_EMPTY:${PN} = "1"
>   INITSCRIPT_PACKAGES = "${PN}-fpm"
>   inherit update-rc.d
>   
> +# WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php: ELF binary /usr/libexec/apache2/modules/libphp.so has relocations in .text [textrel]
> +#WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php-opcache: ELF binary /usr/lib/php8/extensions/no-debug-zts-20200930/opcache.so has relocations in .text [textrel]
> +INSANE_SKIP:${PN}:x86 += "textrel"
> +INSANE_SKIP:${PN}-opcache:x86 += "textrel"
> +

should this use :append instead of += ?

>   FILES:${PN}-dbg =+ "${bindir}/.debug \
>                       ${libexecdir}/apache2/modules/.debug"
>   FILES:${PN}-doc += "${PHP_LIBDIR}/php/doc"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#94678): https://lists.openembedded.org/g/openembedded-devel/message/94678
> Mute This Topic: https://lists.openembedded.org/mt/88257182/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Yu, Mingli Jan. 12, 2022, 8:09 a.m. UTC | #2
On 1/8/22 2:48 AM, Khem Raj wrote:
> [Please note: This e-mail is from an EXTERNAL e-mail address]
> 
> On 1/7/22 12:08 AM, Yu, Mingli wrote:
>> From: Mingli Yu <mingli.yu@windriver.com>
>>
>> Fixes:
>> WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php: ELF 
>> binary /usr/libexec/apache2/modules/libphp.so has relocations in .text 
>> [textrel]
>> WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: 
>> lib32-php-opcache: ELF binary 
>> /usr/lib/php8/extensions/no-debug-zts-20200930/opcache.so has 
>> relocations in .text [textrel]
>>
>> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
>> ---
>>   meta-oe/recipes-devtools/php/php_8.1.0.bb | 5 +++++
>>   1 file changed, 5 insertions(+)
>>
>> diff --git a/meta-oe/recipes-devtools/php/php_8.1.0.bb 
>> b/meta-oe/recipes-devtools/php/php_8.1.0.bb
>> index 593eb3955..fd4a78786 100644
>> --- a/meta-oe/recipes-devtools/php/php_8.1.0.bb
>> +++ b/meta-oe/recipes-devtools/php/php_8.1.0.bb
>> @@ -217,6 +217,11 @@ ALLOW_EMPTY:${PN} = "1"
>>   INITSCRIPT_PACKAGES = "${PN}-fpm"
>>   inherit update-rc.d
>>
>> +# WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php: 
>> ELF binary /usr/libexec/apache2/modules/libphp.so has relocations in 
>> .text [textrel]
>> +#WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: 
>> lib32-php-opcache: ELF binary 
>> /usr/lib/php8/extensions/no-debug-zts-20200930/opcache.so has 
>> relocations in .text [textrel]
>> +INSANE_SKIP:${PN}:x86 += "textrel"
>> +INSANE_SKIP:${PN}-opcache:x86 += "textrel"
>> +
> 
> should this use :append instead of += ?

+= should be okay and it works well with +=.

Thanks,

> 
>>   FILES:${PN}-dbg =+ "${bindir}/.debug \
>>                       ${libexecdir}/apache2/modules/.debug"
>>   FILES:${PN}-doc += "${PHP_LIBDIR}/php/doc"
>>
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#94678): 
>> https://lists.openembedded.org/g/openembedded-devel/message/94678
>> Mute This Topic: https://lists.openembedded.org/mt/88257182/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub 
>> [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>

Patch

diff --git a/meta-oe/recipes-devtools/php/php_8.1.0.bb b/meta-oe/recipes-devtools/php/php_8.1.0.bb
index 593eb3955..fd4a78786 100644
--- a/meta-oe/recipes-devtools/php/php_8.1.0.bb
+++ b/meta-oe/recipes-devtools/php/php_8.1.0.bb
@@ -217,6 +217,11 @@  ALLOW_EMPTY:${PN} = "1"
 INITSCRIPT_PACKAGES = "${PN}-fpm"
 inherit update-rc.d
 
+# WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php: ELF binary /usr/libexec/apache2/modules/libphp.so has relocations in .text [textrel]
+#WARNING: lib32-php-8.0.12-r0 do_package_qa: QA Issue: lib32-php-opcache: ELF binary /usr/lib/php8/extensions/no-debug-zts-20200930/opcache.so has relocations in .text [textrel]
+INSANE_SKIP:${PN}:x86 += "textrel"
+INSANE_SKIP:${PN}-opcache:x86 += "textrel"
+
 FILES:${PN}-dbg =+ "${bindir}/.debug \
                     ${libexecdir}/apache2/modules/.debug"
 FILES:${PN}-doc += "${PHP_LIBDIR}/php/doc"