[meta-python,1/4] python3-paramiko: Upgrade 2.8.0 -> 2.9.1

Message ID 20220106205600.3147781-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/4] python3-paramiko: Upgrade 2.8.0 -> 2.9.1 | expand

Commit Message

Leon Anavi Jan. 6, 2022, 8:55 p.m. UTC
Upgrade to release 2.9.1:

- Add support for SHA-2 variants of RSA key
- Client verification of server host key during key exchange will
  now prefer rsa-sha2-512, rsa-sha2-256, and legacy ssh-rsa
  algorithms, in that order, instead of just ssh-rsa.
- Server mode will now offer all 3 RSA algorithms for host key
  verification during key exchange, similar to client mode, if it
  has been configured with an RSA host key.
- Client mode key exchange now sends the ext-info-c flag signaling
  support for MSG_EXT_INFO, and support for parsing the latter has
  been added.
- SSH agent support grew the ability to specify algorithm flags
  when requesting private key signatures; this is now used to
  forward SHA2 algorithms when appropriate.
- Server mode is now capable of pubkey auth involving SHA-2
  signatures from clients, provided one's server
  implementation actually provides for doing so.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-paramiko_2.8.0.bb => python3-paramiko_2.9.1.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-paramiko_2.8.0.bb => python3-paramiko_2.9.1.bb} (82%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-paramiko_2.8.0.bb b/meta-python/recipes-devtools/python/python3-paramiko_2.9.1.bb
similarity index 82%
rename from meta-python/recipes-devtools/python/python3-paramiko_2.8.0.bb
rename to meta-python/recipes-devtools/python/python3-paramiko_2.9.1.bb
index 1942a1d6c..8cf004aa3 100644
--- a/meta-python/recipes-devtools/python/python3-paramiko_2.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-paramiko_2.9.1.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/paramiko/paramiko/"
 LICENSE = "LGPL-2.1"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fd0120fc2e9f841c73ac707a30389af5"
 
-SRC_URI[sha256sum] = "e673b10ee0f1c80d46182d3af7751d033d9b573dd7054d2d0aa46be186c3c1d2"
+SRC_URI[sha256sum] = "a1fdded3b55f61d23389e4fe52d9ae428960ac958d2edf50373faa5d8926edd0"
 
 PYPI_PACKAGE = "paramiko"