diff mbox series

[meta-python,13/26] python3-cbor2: upgrade 5.6.1 -> 5.6.2

Message ID 1709714608-19296-13-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-oe,01/26] abseil-cpp: upgrade 20230802.1 -> 20240116.1 | expand

Commit Message

Mingyu Wang (Fujitsu) March 6, 2024, 8:43 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
-Fixed __hash__() of the C version of the CBORTag type crashing when there's a
 recursive reference cycle
-Fixed type annotation for the file object in cbor2.dump(), cbor2.load(),
 CBOREncoder and CBORDecoder to be IO[bytes] instead of BytesIO
-Worked around a CPython bug that caused a SystemError to be raised, or even a
 buffer overflow to occur when decoding a long text string that contained only
 ASCII characters
-Changed the return type annotations of cbor2.load() and cbor2.load() to return
 Any instead of object so as not to force users to make type casts

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-cbor2_5.6.1.bb => python3-cbor2_5.6.2.bb}   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-cbor2_5.6.1.bb => python3-cbor2_5.6.2.bb} (89%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb b/meta-python/recipes-devtools/python/python3-cbor2_5.6.2.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb
rename to meta-python/recipes-devtools/python/python3-cbor2_5.6.2.bb
index e2493e4e1..c0987a9a1 100644
--- a/meta-python/recipes-devtools/python/python3-cbor2_5.6.1.bb
+++ b/meta-python/recipes-devtools/python/python3-cbor2_5.6.2.bb
@@ -4,7 +4,7 @@  DEPENDS +="python3-setuptools-scm-native"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
-SRC_URI[sha256sum] = "752130e38644319f3dae7f91fabb08f58bc454ca671b72875e6228d423890efd"
+SRC_URI[sha256sum] = "b7513c2dea8868991fad7ef8899890ebcf8b199b9b4461c3c11d7ad3aef4820d"
 
 inherit pypi python_setuptools_build_meta ptest