diff mbox series

[meta-python,2/2] python3-pydantic: upgrade 2.5.3 -> 2.6.0

Message ID 1708568553-2751-2-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python,1/2] python3-pydantic-core: upgrade 2.14.6 -> 2.16.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 22, 2024, 2:22 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Drop Python3.7 support
-Drop Python 3.7, and PyPy 3.7 and 3.8
-Use positional-only self in BaseModel constructor, so no field name can ever
 conflict with it
-Make @validate_call return a function instead of a custom descriptor - fixes
 binding issue with inheritance and adds self/cls argument to validation errors
-Exclude BaseModel docstring from JSON schema description
-Introducing classproperty decorator for model_computed_fields
-Explicitly raise an error if field names clashes with types
-Use stricter serializer for unions of simple types

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pydantic_2.5.3.bb => python3-pydantic_2.6.0.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pydantic_2.5.3.bb => python3-pydantic_2.6.0.bb} (94%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb b/meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
similarity index 94%
rename from meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb
rename to meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
index 21341d26c..af465f423 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic_2.5.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic_2.6.0.bb
@@ -11,7 +11,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
 
 inherit pypi python_hatchling
 
-SRC_URI[sha256sum] = "b3ef57c62535b0941697cce638c08900d87fcb67e29cfa99e8a68f747f393f7a"
+SRC_URI[sha256sum] = "ae887bd94eb404b09d86e4d12f93893bdca79d766e738528c6fa1c849f3c6bcf"
 
 DEPENDS += "python3-hatch-fancy-pypi-readme-native"