diff mbox series

[meta-python,19/23] python3-django: upgrade 5.0.1 -> 5.0.2

Message ID 1708333346-17704-19-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-gnome,01/23] babl: upgrade 0.1.106 -> 0.1.108 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 19, 2024, 9:02 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Reallowed, following a regression in Django 5.0.1, filtering against local
 foreign keys not included in ModelAdmin.list_filter (#35087).
-Fixed a regression in Django 5.0 where links in the admin had an incorrect
 color (#35121).
-Fixed a bug in Django 5.0 that caused a crash of Model.full_clean() on
 models with a GeneratedField (#35127).
-Fixed a regression in Django 5.0 that caused a crash of FilteredRelation()
 with querysets as right-hand sides (#35135). FilteredRelation() now raises
 a ValueError on querysets as right-hand sides.
-Fixed a regression in Django 5.0 that caused a crash of the dumpdata
 management command when a base queryset used prefetch_related() (#35159).
-Fixed a regression in Django 5.0 that caused the request_finished signal to
 sometimes not be fired when running Django through an ASGI server, resulting
 in potential resource leaks (#35059).
-Fixed a bug in Django 5.0 that caused a migration crash on MySQL when adding
 a BinaryField, TextField, JSONField, or GeometryField with a db_default (#35162).
-Fixed a bug in Django 5.0 that caused a migration crash on models with a
 literal db_default of a complex type such as dict instance of a JSONField.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-django_5.0.1.bb => python3-django_5.0.2.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-django_5.0.1.bb => python3-django_5.0.2.bb} (58%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-django_5.0.1.bb b/meta-python/recipes-devtools/python/python3-django_5.0.2.bb
similarity index 58%
rename from meta-python/recipes-devtools/python/python3-django_5.0.1.bb
rename to meta-python/recipes-devtools/python/python3-django_5.0.2.bb
index eed1e6edc..318b62408 100644
--- a/meta-python/recipes-devtools/python/python3-django_5.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-django_5.0.2.bb
@@ -1,7 +1,7 @@ 
 require python-django.inc
 inherit setuptools3
 
-SRC_URI[sha256sum] = "8c8659665bc6e3a44fefe1ab0a291e5a3fb3979f9a8230be29de975e57e8f854"
+SRC_URI[sha256sum] = "b5bb1d11b2518a5f91372a282f24662f58f66749666b0a286ab057029f728080"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-sqlparse \