diff mbox series

[meta-python] python3-pylint: upgrade 3.0.2 -> 3.0.3

Message ID 1702599513-1613-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-pylint: upgrade 3.0.2 -> 3.0.3 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 15, 2023, 12:18 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Fixed false positive for unnecessary-lambda when the call has keyword
 arguments but not the lambda.
-Fixed incorrect suggestion for shallow copy in unnecessary-comprehension
-Fix false positives for undefined-variable and unused-argument for
 classes and functions using Python 3.12 generic type syntax.
-Fixed pointless-string-statement false positive for docstrings
 on Python 3.12 type aliases.
-Fix false positive for invalid-exception-operation when concatenating tuples
 of exception types.
-Fix a bug where pylint was unable to walk recursively through a directory if
 the directory has an __init__.py file.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-pylint_3.0.2.bb => python3-pylint_3.0.3.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pylint_3.0.2.bb => python3-pylint_3.0.3.bb} (97%)

Comments

Khem Raj Dec. 19, 2023, 6:27 a.m. UTC | #1
On Fri, 15 Dec 2023 08:18:33 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ===========
> -Fixed false positive for unnecessary-lambda when the call has keyword
>  arguments but not the lambda.
> -Fixed incorrect suggestion for shallow copy in unnecessary-comprehension
> -Fix false positives for undefined-variable and unused-argument for
>  classes and functions using Python 3.12 generic type syntax.
> -Fixed pointless-string-statement false positive for docstrings
>  on Python 3.12 type aliases.
> -Fix false positive for invalid-exception-operation when concatenating tuples
>  of exception types.
> -Fix a bug where pylint was unable to walk recursively through a directory if
>  the directory has an __init__.py file.
> 
> [...]

Applied, thanks!

[1/1] python3-pylint: upgrade 3.0.2 -> 3.0.3
      commit: 6580c4bb38ece6f0775c550e36ee5da89352d500

Best regards,
Khem Raj Dec. 27, 2023, 3:46 p.m. UTC | #2
btw, there is a ptest failure

    Failed ptests:
    {'python3-pylint':
['tests/test_functional.py::test_functional[deprecated_module_py310]',

'tests/test_functional.py::test_functional[regression_distutil_import_error_73]']}

Csn you look into it ?

bitbake meta-python3-ptest-python3-pylint
should be able to show these failures with ptest in distro features.

On Thu, Dec 14, 2023 at 4:19 PM wangmy <wangmy@fujitsu.com> wrote:
>
> From: Wang Mingyu <wangmy@fujitsu.com>
>
> Changelog:
> ===========
> -Fixed false positive for unnecessary-lambda when the call has keyword
>  arguments but not the lambda.
> -Fixed incorrect suggestion for shallow copy in unnecessary-comprehension
> -Fix false positives for undefined-variable and unused-argument for
>  classes and functions using Python 3.12 generic type syntax.
> -Fixed pointless-string-statement false positive for docstrings
>  on Python 3.12 type aliases.
> -Fix false positive for invalid-exception-operation when concatenating tuples
>  of exception types.
> -Fix a bug where pylint was unable to walk recursively through a directory if
>  the directory has an __init__.py file.
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../python/{python3-pylint_3.0.2.bb => python3-pylint_3.0.3.bb} | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>  rename meta-python/recipes-devtools/python/{python3-pylint_3.0.2.bb => python3-pylint_3.0.3.bb} (97%)
>
> diff --git a/meta-python/recipes-devtools/python/python3-pylint_3.0.2.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb
> similarity index 97%
> rename from meta-python/recipes-devtools/python/python3-pylint_3.0.2.bb
> rename to meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb
> index 8af74b7cb..09ab1f26f 100644
> --- a/meta-python/recipes-devtools/python/python3-pylint_3.0.2.bb
> +++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb
> @@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
>  SRC_URI += "git://github.com/pylint-dev/pylint;branch=maintenance/3.0.x;protocol=https \
>             file://run-ptest \
>             "
> -SRCREV = "efee9618894795cc8847727108522aa79431ee25"
> +SRCREV = "1a5ffc1f447b77071ffe18a9c6836c09147ee2ed"
>
>  inherit python_setuptools_build_meta ptest
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107471): https://lists.openembedded.org/g/openembedded-devel/message/107471
> Mute This Topic: https://lists.openembedded.org/mt/103181847/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pylint_3.0.2.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb
similarity index 97%
rename from meta-python/recipes-devtools/python/python3-pylint_3.0.2.bb
rename to meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb
index 8af74b7cb..09ab1f26f 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_3.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb
@@ -6,7 +6,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
 SRC_URI += "git://github.com/pylint-dev/pylint;branch=maintenance/3.0.x;protocol=https \
            file://run-ptest \
            "
-SRCREV = "efee9618894795cc8847727108522aa79431ee25"
+SRCREV = "1a5ffc1f447b77071ffe18a9c6836c09147ee2ed"
 
 inherit python_setuptools_build_meta ptest