diff mbox series

[meta-python] python3-pytest-asyncio: upgrade 0.22.0 -> 0.23.2

Message ID 1702544659-28375-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-pytest-asyncio: upgrade 0.22.0 -> 0.23.2 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 14, 2023, 9:04 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Fixes a bug that caused an internal pytest error when collecting .txt files
-Fixes a bug that caused an internal pytest error when using module-level skips
-This release is backwards-compatible with v0.21. Changes are non-breaking,
 unless you upgrade from v0.22.
-BREAKING: The asyncio_event_loop mark has been removed. Event loops with class,
 module, package, and session scopes can be requested via the scope keyword
 argument to the _asyncio_ mark.
-Introduces the event_loop_policy fixture which allows testing with non-default
 or multiple event loops
-Introduces pytest_asyncio.is_async_test which returns whether a test item is
 managed by pytest-asyncio
-Removes and pytest-trio, mypy, and flaky from the test dependencies

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ytest-asyncio_0.22.0.bb => python3-pytest-asyncio_0.23.2.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pytest-asyncio_0.22.0.bb => python3-pytest-asyncio_0.23.2.bb} (81%)

Comments

Khem Raj Dec. 19, 2023, 6:27 a.m. UTC | #1
On Thu, 14 Dec 2023 17:04:19 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ============
> -Fixes a bug that caused an internal pytest error when collecting .txt files
> -Fixes a bug that caused an internal pytest error when using module-level skips
> -This release is backwards-compatible with v0.21. Changes are non-breaking,
>  unless you upgrade from v0.22.
> -BREAKING: The asyncio_event_loop mark has been removed. Event loops with class,
>  module, package, and session scopes can be requested via the scope keyword
>  argument to the _asyncio_ mark.
> -Introduces the event_loop_policy fixture which allows testing with non-default
>  or multiple event loops
> -Introduces pytest_asyncio.is_async_test which returns whether a test item is
>  managed by pytest-asyncio
> -Removes and pytest-trio, mypy, and flaky from the test dependencies
> 
> [...]

Applied, thanks!

[1/1] python3-pytest-asyncio: upgrade 0.22.0 -> 0.23.2
      commit: 616fb9ccb7c69992a3bbe6cb29d1ffd6ae524d77

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.22.0.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.23.2.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-pytest-asyncio_0.22.0.bb
rename to meta-python/recipes-devtools/python/python3-pytest-asyncio_0.23.2.bb
index 8fa77ac05..a00778c99 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.22.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.23.2.bb
@@ -3,7 +3,7 @@  DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python,
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=136e4f49dbf29942c572a3a8f6e88a77"
 
-SRC_URI[sha256sum] = "01da1bf94ff0b969cc8d760104f7c1011903d0d658bdaef0bbae769660a7fbc4"
+SRC_URI[sha256sum] = "c16052382554c7b22d48782ab3438d5b10f8cf7a4bdcae7f0f67f097d95beecc"
 
 inherit pypi python_setuptools_build_meta