diff mbox series

[meta-python] python3-isort: upgrade 5.12.0 -> 5.13.1

Message ID 1702544301-28120-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-isort: upgrade 5.12.0 -> 5.13.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 14, 2023, 8:58 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Fixed integration tests
-Fixed normalizing imports from more than one level of parent modules
-Remove optional dependencies without extras
-Cleanup deprecated extras
-Fixed #1989: settings lookup when working in stream based mode
-Fixed 80 line length for wemake linter
-Add support for Python 3.12 75
-Fixed: add newest version to pre-commit docs
-Fixed assertions in test_git_hook
-Removed check for include_trailing_comma for the Hanging Indent wrap mode
-Use the standard library tomllib on sufficiently new python
-Update pre-commit.md version number
-doc: Update black_compatibility.md
-Fixed safety sept 2023
-docs: fix black profile documentation
-Fixed typo: indended -> indented
-Docs(configuration/options.md): fix missing trailing spaces for hard linebreak
-Update pre-commit.md
-chore: move configurations to pyproject.toml
-Fixed typo in README
-Update version in pre-commit setup to avoid installation issue with poetry
-Skip .pytype directory by default.
-Fixed a tip block styling in the Config Files section
-Do not cache configuration files
-Derive settings_path from --filename
-Fixed year of version 5.12.0 in CHANGELOG.md

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-isort_5.12.0.bb => python3-isort_5.13.1.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-isort_5.12.0.bb => python3-isort_5.13.1.bb} (85%)

Comments

Khem Raj Dec. 19, 2023, 6:27 a.m. UTC | #1
On Thu, 14 Dec 2023 16:58:21 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ============
> -Fixed integration tests
> -Fixed normalizing imports from more than one level of parent modules
> -Remove optional dependencies without extras
> -Cleanup deprecated extras
> -Fixed #1989: settings lookup when working in stream based mode
> -Fixed 80 line length for wemake linter
> -Add support for Python 3.12 75
> -Fixed: add newest version to pre-commit docs
> -Fixed assertions in test_git_hook
> -Removed check for include_trailing_comma for the Hanging Indent wrap mode
> -Use the standard library tomllib on sufficiently new python
> -Update pre-commit.md version number
> -doc: Update black_compatibility.md
> -Fixed safety sept 2023
> -docs: fix black profile documentation
> -Fixed typo: indended -> indented
> -Docs(configuration/options.md): fix missing trailing spaces for hard linebreak
> -Update pre-commit.md
> -chore: move configurations to pyproject.toml
> -Fixed typo in README
> -Update version in pre-commit setup to avoid installation issue with poetry
> -Skip .pytype directory by default.
> -Fixed a tip block styling in the Config Files section
> -Do not cache configuration files
> -Derive settings_path from --filename
> -Fixed year of version 5.12.0 in CHANGELOG.md
> 
> [...]

Applied, thanks!

[1/1] python3-isort: upgrade 5.12.0 -> 5.13.1
      commit: 36df077879a3116ca1fbf9a16fab2b0b4f2c5346

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-isort_5.12.0.bb b/meta-python/recipes-devtools/python/python3-isort_5.13.1.bb
similarity index 85%
rename from meta-python/recipes-devtools/python/python3-isort_5.12.0.bb
rename to meta-python/recipes-devtools/python/python3-isort_5.13.1.bb
index d111393ea..f8deaae08 100644
--- a/meta-python/recipes-devtools/python/python3-isort_5.12.0.bb
+++ b/meta-python/recipes-devtools/python/python3-isort_5.13.1.bb
@@ -4,7 +4,7 @@  LICENSE = "MIT"
 SECTION = "devel/python"
 LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148f94f483f3e1489"
 
-SRC_URI[sha256sum] = "8bef7dde241278824a6d83f44a544709b065191b95b6e50894bdc722fcba0504"
+SRC_URI[sha256sum] = "aaed790b463e8703fb1eddb831dfa8e8616bacde2c083bd557ef73c8189b7263"
 
 inherit pypi python_poetry_core