diff mbox series

[meta-python] python3-google-api-core: upgrade 2.14.0 -> 2.15.0

Message ID 1702544005-27841-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-google-api-core: upgrade 2.14.0 -> 2.15.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 14, 2023, 8:53 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
-Add support for Python 3.12
-Add type annotations to wrapped grpc calls
-Add universe_domain argument to ClientOptions
-Introduce compatibility with native namespace packages
-Fix regression in bidi causing Thread-ConsumeBidirectionalStream caught
 unexpected exception and will exit
-Replace deprecated datetime.datetime.utcnow() 

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...gle-api-core_2.14.0.bb => python3-google-api-core_2.15.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-google-api-core_2.14.0.bb => python3-google-api-core_2.15.0.bb} (86%)

Comments

Khem Raj Dec. 19, 2023, 6:27 a.m. UTC | #1
On Thu, 14 Dec 2023 16:53:25 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ==========
> -Add support for Python 3.12
> -Add type annotations to wrapped grpc calls
> -Add universe_domain argument to ClientOptions
> -Introduce compatibility with native namespace packages
> -Fix regression in bidi causing Thread-ConsumeBidirectionalStream caught
>  unexpected exception and will exit
> -Replace deprecated datetime.datetime.utcnow()
> 
> [...]

Applied, thanks!

[1/1] python3-google-api-core: upgrade 2.14.0 -> 2.15.0
      commit: 186765ab8d552744aaa71bb5d7449aa06f0dca71

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-google-api-core_2.14.0.bb b/meta-python/recipes-devtools/python/python3-google-api-core_2.15.0.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-google-api-core_2.14.0.bb
rename to meta-python/recipes-devtools/python/python3-google-api-core_2.15.0.bb
index b620e553e..7ce2ad7ad 100644
--- a/meta-python/recipes-devtools/python/python3-google-api-core_2.14.0.bb
+++ b/meta-python/recipes-devtools/python/python3-google-api-core_2.15.0.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "5368a4502b793d9bbf812a5912e13e4e69f9bd87f6efb508460c43f5bbd1ce41"
+SRC_URI[sha256sum] = "abc978a72658f14a2df1e5e12532effe40f94f868f6e23d95133bd6abcca35ca"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-asyncio \