diff mbox series

[meta-python] python3-flask-restx: upgrade 1.2.0 -> 1.3.0

Message ID 1702543900-27748-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-flask-restx: upgrade 1.2.0 -> 1.3.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 14, 2023, 8:51 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
* Fixing werkzeug 3 deprecated version import. Import is replaced by new style version check with importlib
* Fixing flask 3.0+ compatibility of 'ModuleNotFoundError: No module named 'flask.scaffold'' Import error.
* Fix wrong status code and message on responses when handling 'HTTPExceptions'
* Add flask 2 and flask 3 to testing matrix.
* Update internally pinned pytest-flask to 1.3.0 for Flask >=3.0.0 support.
* Python 3.12 support.
* Fix wrong status code and message on responses when handling HTTPExceptions.
* Update changelog Flask version table.
* Remove temporary package version restrictions for flask < 3.0.0, werkzeug and jsonschema

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ython3-flask-restx_1.2.0.bb => python3-flask-restx_1.3.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-flask-restx_1.2.0.bb => python3-flask-restx_1.3.0.bb} (78%)

Comments

Khem Raj Dec. 19, 2023, 6:27 a.m. UTC | #1
On Thu, 14 Dec 2023 16:51:40 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ============
> * Fixing werkzeug 3 deprecated version import. Import is replaced by new style version check with importlib
> * Fixing flask 3.0+ compatibility of 'ModuleNotFoundError: No module named 'flask.scaffold'' Import error.
> * Fix wrong status code and message on responses when handling 'HTTPExceptions'
> * Add flask 2 and flask 3 to testing matrix.
> * Update internally pinned pytest-flask to 1.3.0 for Flask >=3.0.0 support.
> * Python 3.12 support.
> * Fix wrong status code and message on responses when handling HTTPExceptions.
> * Update changelog Flask version table.
> * Remove temporary package version restrictions for flask < 3.0.0, werkzeug and jsonschema
> 
> [...]

Applied, thanks!

[1/1] python3-flask-restx: upgrade 1.2.0 -> 1.3.0
      commit: eaa7d950ed3bd848bc65ca57d92ae073f679b22d

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb b/meta-python/recipes-devtools/python/python3-flask-restx_1.3.0.bb
similarity index 78%
rename from meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb
rename to meta-python/recipes-devtools/python/python3-flask-restx_1.3.0.bb
index 573c2dbff..9c2a1e9a8 100644
--- a/meta-python/recipes-devtools/python/python3-flask-restx_1.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-restx_1.3.0.bb
@@ -2,7 +2,7 @@  DESCRIPTION = "Fully featured framework for fast, easy and documented API develo
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=c96dd911c6d9e32868b6bc667a38a3e2"
 
-SRC_URI[sha256sum] = "9a5338b108c57fbed1d24d5d53fe98442b2be7ffa2ff3291305af7a613ce6fc0"
+SRC_URI[sha256sum] = "4f3d3fa7b6191fcc715b18c201a12cd875176f92ba4acc61626ccfd571ee1728"
 
 inherit pypi setuptools3