diff mbox series

[meta-python] python3-bitarray: upgrade 2.8.3 -> 2.8.5

Message ID 1702543692-27565-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-bitarray: upgrade 2.8.3 -> 2.8.5 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 14, 2023, 8:48 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
* speedup unaligned copies by always using word shifts (in combination
  with builtin byte swap 64 when available) when bit-endianness and
  machine byte-order are opposite
* add 'HAVE_BUILTIN_BSWAP64' to header
* avoid misaligned pointers when casting to '(uint64_t *)'
* add tests
* simplify 'copy_n()' (remove special cases), see #d2d6fd53
* add [word shift example C program](../examples/shift_r8.c),
  and simplify 'shift_r8()'
* improve documentation and testing
* add [roadmap](https://github.com/ilanschnell/bitarray#roadmap)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-bitarray_2.8.3.bb => python3-bitarray_2.8.5.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-bitarray_2.8.3.bb => python3-bitarray_2.8.5.bb} (80%)

Comments

Khem Raj Dec. 19, 2023, 6:27 a.m. UTC | #1
On Thu, 14 Dec 2023 16:48:12 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ============
> * speedup unaligned copies by always using word shifts (in combination
>   with builtin byte swap 64 when available) when bit-endianness and
>   machine byte-order are opposite
> * add 'HAVE_BUILTIN_BSWAP64' to header
> * avoid misaligned pointers when casting to '(uint64_t *)'
> * add tests
> * simplify 'copy_n()' (remove special cases), see #d2d6fd53
> * add [word shift example C program](../examples/shift_r8.c),
>   and simplify 'shift_r8()'
> * improve documentation and testing
> * add [roadmap](https://github.com/ilanschnell/bitarray#roadmap)
> 
> [...]

Applied, thanks!

[1/1] python3-bitarray: upgrade 2.8.3 -> 2.8.5
      commit: 02e05067e82646b9b6e9ea44d491a6c859427b1f

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-bitarray_2.8.3.bb b/meta-python/recipes-devtools/python/python3-bitarray_2.8.5.bb
similarity index 80%
rename from meta-python/recipes-devtools/python/python3-bitarray_2.8.3.bb
rename to meta-python/recipes-devtools/python/python3-bitarray_2.8.5.bb
index acacdab6d..5047784ab 100644
--- a/meta-python/recipes-devtools/python/python3-bitarray_2.8.3.bb
+++ b/meta-python/recipes-devtools/python/python3-bitarray_2.8.5.bb
@@ -4,7 +4,7 @@  HOMEPAGE = "https://github.com/ilanschnell/bitarray"
 LICENSE = "PSF-2.0"
 LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d"
 
-SRC_URI[sha256sum] = "e15587b2bdf18d32eb3ba25f5f5a51bedd0dc06b3112a4c53dab5e7753bc6588"
+SRC_URI[sha256sum] = "b7564fd218cc4479f7f0106d341e096f78907b47865aeeff702c807df1927c01"
 
 inherit setuptools3 pypi