diff mbox series

[meta-python] python3-sentry-sdk: upgrade 1.35.0 -> 1.37.1

Message ID 1701160971-28544-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-sentry-sdk: upgrade 1.35.0 -> 1.37.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 28, 2023, 8:42 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Fix NameError on parse_version with eventlet
-build(deps): bump checkouts/data-schemas from 68def1e to e9f7d58
-Move installed modules code to utils
-Note: We moved the internal function _get_installed_modules from
 sentry_sdk.integrations.modules to sentry_sdk.utils. So if you use this
 function you have to update your imports
-Add code locations for metrics
-Add query source to DB spans
-Send events to Spotlight sidecar
-Run integration tests with newest pytest
-Bring tests up to date
-Fix: Prevent global var from being discarded at shutdown
-Fix: Scope transaction source not being updated in scope.span setter
-Django: Support Django 5.0
-Django: Handling ASGI body in the right way.
-Flask: Test with Flask 3.0
-Celery: Do not create a span when task is triggered by Celery Beat
-Redis: Ensure RedisIntegration is disabled, unless redis is installed
-Quart: Fix Quart integration for Quart 0.19.4
-gRPC: Make async gRPC less noisy

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ython3-sentry-sdk_1.35.0.bb => python3-sentry-sdk_1.37.1.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-sentry-sdk_1.35.0.bb => python3-sentry-sdk_1.37.1.bb} (86%)

Comments

Khem Raj Nov. 28, 2023, 11:55 p.m. UTC | #1
On Tue, 28 Nov 2023 16:42:51 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ===========
> -Fix NameError on parse_version with eventlet
> -build(deps): bump checkouts/data-schemas from 68def1e to e9f7d58
> -Move installed modules code to utils
> -Note: We moved the internal function _get_installed_modules from
>  sentry_sdk.integrations.modules to sentry_sdk.utils. So if you use this
>  function you have to update your imports
> -Add code locations for metrics
> -Add query source to DB spans
> -Send events to Spotlight sidecar
> -Run integration tests with newest pytest
> -Bring tests up to date
> -Fix: Prevent global var from being discarded at shutdown
> -Fix: Scope transaction source not being updated in scope.span setter
> -Django: Support Django 5.0
> -Django: Handling ASGI body in the right way.
> -Flask: Test with Flask 3.0
> -Celery: Do not create a span when task is triggered by Celery Beat
> -Redis: Ensure RedisIntegration is disabled, unless redis is installed
> -Quart: Fix Quart integration for Quart 0.19.4
> -gRPC: Make async gRPC less noisy
> 
> [...]

Applied, thanks!

[1/1] python3-sentry-sdk: upgrade 1.35.0 -> 1.37.1
      commit: aff494f4c071b7d88525436ace810a866d10c3ea

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.35.0.bb b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.37.1.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-sentry-sdk_1.35.0.bb
rename to meta-python/recipes-devtools/python/python3-sentry-sdk_1.37.1.bb
index b2bc875f5..868a7e2f3 100644
--- a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.35.0.bb
+++ b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.37.1.bb
@@ -15,7 +15,7 @@  RDEPENDS:${PN} += "\
 	${PYTHON_PN}-datetime \
 "
 
-SRC_URI[sha256sum] = "04e392db9a0d59bd49a51b9e3a92410ac5867556820465057c2ef89a38e953e9"
+SRC_URI[sha256sum] = "7cd324dd2877fdc861f75cba4242bce23a58272a6fea581fcb218bb718bd9cc5"
 
 PYPI_PACKAGE = "sentry-sdk"