diff mbox series

[meta-oe] paho-mqtt-cpp: upgrade 1.2.0 -> 1.3.1

Message ID 1701159692-27917-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-oe] paho-mqtt-cpp: upgrade 1.2.0 -> 1.3.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 28, 2023, 8:21 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-cmake-Use-CMAKE_INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch
refreshed for 1.3.1

License-Update: Updated license to EPL-v2.0

Changelog:
============
-#462 Fix version string for version v1.3.x
-Fixed building and using library as DLL on Windows with MSVC
-Updated License to Eclipse Public License v2.0
-Updated create and connect options to better deal with MQTT protocol version
-Defaulting connect version to v5 if specified in create options.
-Added a topic_filter class to match a single filter to specific topics.
-Added a topic_matcher class to create a collection of items in a trie structure
 that can contain items tied to topic filters. (Useful for queues or callbacks
 per-subscription topic).
-Minor tweaks to prepare for C++20
-Support for Catch2 v3.x for unit tests (v2.x also still supported).
-Changed the sample apps to use the newer "mqtt://" schemas.
-Connect option initializers for v5 and WebSockets.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch | 26 ++++++++++++-------
 ...tt-cpp_1.2.0.bb => paho-mqtt-cpp_1.3.1.bb} |  8 +++---
 2 files changed, 21 insertions(+), 13 deletions(-)
 rename meta-oe/recipes-connectivity/paho-mqtt-cpp/{paho-mqtt-cpp_1.2.0.bb => paho-mqtt-cpp_1.3.1.bb} (73%)

Comments

Khem Raj Nov. 28, 2023, 11:55 p.m. UTC | #1
On Tue, 28 Nov 2023 16:21:32 +0800, wangmy@fujitsu.com wrote:
> 0001-cmake-Use-CMAKE_INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch
> refreshed for 1.3.1
> 
> License-Update: Updated license to EPL-v2.0
> 
> Changelog:
> ============
> -#462 Fix version string for version v1.3.x
> -Fixed building and using library as DLL on Windows with MSVC
> -Updated License to Eclipse Public License v2.0
> -Updated create and connect options to better deal with MQTT protocol version
> -Defaulting connect version to v5 if specified in create options.
> -Added a topic_filter class to match a single filter to specific topics.
> -Added a topic_matcher class to create a collection of items in a trie structure
>  that can contain items tied to topic filters. (Useful for queues or callbacks
>  per-subscription topic).
> -Minor tweaks to prepare for C++20
> -Support for Catch2 v3.x for unit tests (v2.x also still supported).
> -Changed the sample apps to use the newer "mqtt://" schemas.
> -Connect option initializers for v5 and WebSockets.
> 
> [...]

Applied, thanks!

[1/1] paho-mqtt-cpp: upgrade 1.2.0 -> 1.3.1
      commit: e4fa64c59618711dbf6621a66e0db5c840e7536c

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp/0001-cmake-Use-CMAKE_INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch b/meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp/0001-cmake-Use-CMAKE_INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch
index 2436b36f2..fba9a8767 100644
--- a/meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp/0001-cmake-Use-CMAKE_INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch
+++ b/meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp/0001-cmake-Use-CMAKE_INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch
@@ -8,7 +8,7 @@  This ensures the install paths are not hardcoded.
 Signed-off-by: Khem Raj <raj.khem@gmail.com>
 ---
 Upstream-Status: Pending
-
+---
  cmake/CMakeLists.txt       | 4 ++--
  src/samples/CMakeLists.txt | 4 ++--
  2 files changed, 4 insertions(+), 4 deletions(-)
@@ -33,19 +33,27 @@  index a9f8908..7eadc60 100644
 -    DESTINATION lib/cmake/${package_name})
 +    DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${package_name})
 diff --git a/src/samples/CMakeLists.txt b/src/samples/CMakeLists.txt
-index 953f5dc..d26729a 100644
+index 3ca0a75..c915cd5 100644
 --- a/src/samples/CMakeLists.txt
 +++ b/src/samples/CMakeLists.txt
-@@ -103,7 +103,7 @@ endif()
+@@ -71,7 +71,7 @@ endforeach()
  
  ## install binaries
- install(TARGETS ${INSTALL_TARGETS} EXPORT PahoMqttCppSamples
--	RUNTIME DESTINATION bin
--	LIBRARY DESTINATION lib
-+	RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-+	LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ install(TARGETS ${EXECUTABLES} EXPORT PahoMqttCppSamples
+-  RUNTIME DESTINATION bin
++  RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
  )
  
+ ## Build the SSL/TLS samples, if selected
+@@ -89,7 +89,7 @@ if(PAHO_WITH_SSL)
+   endforeach()
+ 
+   install(TARGETS ${SSL_EXECUTABLES} EXPORT PahoMqttCppSamples
+-    RUNTIME DESTINATION bin
++    RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+   )
+ endif()
+ 
 -- 
-2.35.1
+2.34.1
 
diff --git a/meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp_1.2.0.bb b/meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp_1.3.1.bb
similarity index 73%
rename from meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp_1.2.0.bb
rename to meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp_1.3.1.bb
index bb5aa6907..1e1e92339 100644
--- a/meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp_1.2.0.bb
+++ b/meta-oe/recipes-connectivity/paho-mqtt-cpp/paho-mqtt-cpp_1.3.1.bb
@@ -2,18 +2,18 @@  SUMMARY = "Paho MQTT - C++ libraries for the MQTT and MQTT-SN protocols"
 DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)."
 HOMEPAGE = "http://www.eclipse.org/paho/"
 SECTION = "console/network"
-LICENSE = "EPL-1.0 | EDL-1.0"
+LICENSE = "EPL-2.0 | EDL-1.0"
 
 LIC_FILES_CHKSUM = " \
-    file://src/mqtt/message.h;beginline=9;endline=18;md5=5eec304e6066523386c222963ceeb6ff \
+    file://src/mqtt/message.h;beginline=9;endline=18;md5=c5ceecf5ab99d44dcfaaabdce289071b \
     file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \
-    file://epl-v10;md5=659c8e92a40b6df1d9e3dccf5ae45a08 \
+    file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \
 "
 
 SRC_URI = "git://github.com/eclipse/paho.mqtt.cpp;protocol=https;branch=master \
            file://0001-cmake-Use-CMAKE_INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch \
 "
-SRCREV = "33921c8b68b351828650c36816e7ecf936764379"
+SRCREV = "4691652479bb4b398c7b81bde639482b164ae6d6"
 
 DEPENDS = "openssl paho-mqtt-c"