diff mbox series

[meta-python] python3-django: upgrade 4.2.5 -> 4.2.7

Message ID 1700634135-7982-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-django: upgrade 4.2.5 -> 4.2.7 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 22, 2023, 6:22 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Fixed a regression in Django 4.2 that caused a crash of QuerySet.aggregate()
 with aggregates referencing expressions containing subqueries (#34798).
-Restored, following a regression in Django 4.2, creating
 varchar/text_pattern_ops indexes on CharField and TextField with
 deterministic collations on PostgreSQL (#34932).
-CVE-2023-46695: Potential denial of service vulnerability in UsernameField on Windows
-Fixed a regression in Django 4.2.5 where overriding the deprecated
 DEFAULT_FILE_STORAGE and STATICFILES_STORAGE settings in tests caused the main
 STORAGES to mutate (#34821).
-Fixed a regression in Django 4.2 that caused unnecessary casting of string
 based fields (CharField, EmailField, TextField, CICharField, CIEmailField, and
 CITextField) used with the __isnull lookup on PostgreSQL.
-CVE-2023-43665: Denial-of-service possibility in django.utils.text.Truncator

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-django_4.2.5.bb => python3-django_4.2.7.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-django_4.2.5.bb => python3-django_4.2.7.bb} (58%)

Comments

Khem Raj Nov. 24, 2023, 12:01 a.m. UTC | #1
On Wed, 22 Nov 2023 14:22:15 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ===========
> -Fixed a regression in Django 4.2 that caused a crash of QuerySet.aggregate()
>  with aggregates referencing expressions containing subqueries (#34798).
> -Restored, following a regression in Django 4.2, creating
>  varchar/text_pattern_ops indexes on CharField and TextField with
>  deterministic collations on PostgreSQL (#34932).
> -CVE-2023-46695: Potential denial of service vulnerability in UsernameField on Windows
> -Fixed a regression in Django 4.2.5 where overriding the deprecated
>  DEFAULT_FILE_STORAGE and STATICFILES_STORAGE settings in tests caused the main
>  STORAGES to mutate (#34821).
> -Fixed a regression in Django 4.2 that caused unnecessary casting of string
>  based fields (CharField, EmailField, TextField, CICharField, CIEmailField, and
>  CITextField) used with the __isnull lookup on PostgreSQL.
> -CVE-2023-43665: Denial-of-service possibility in django.utils.text.Truncator
> 
> [...]

Applied, thanks!

[1/1] python3-django: upgrade 4.2.5 -> 4.2.7
      commit: 8f8c96e1ca7f3b3f1b84c62215cfc864dca24419

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-django_4.2.5.bb b/meta-python/recipes-devtools/python/python3-django_4.2.7.bb
similarity index 58%
rename from meta-python/recipes-devtools/python/python3-django_4.2.5.bb
rename to meta-python/recipes-devtools/python/python3-django_4.2.7.bb
index bc919b3a8..100db9bd7 100644
--- a/meta-python/recipes-devtools/python/python3-django_4.2.5.bb
+++ b/meta-python/recipes-devtools/python/python3-django_4.2.7.bb
@@ -1,7 +1,7 @@ 
 require python-django.inc
 inherit setuptools3
 
-SRC_URI[sha256sum] = "5e5c1c9548ffb7796b4a8a4782e9a2e5a3df3615259fc1bfd3ebc73b646146c1"
+SRC_URI[sha256sum] = "8e0f1c2c2786b5c0e39fe1afce24c926040fad47c8ea8ad30aaf1188df29fc41"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-sqlparse \