diff mbox series

[meta-python] python3-google-api-core: upgrade 2.12.0 -> 2.14.0

Message ID 1700122555-22095-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-google-api-core: upgrade 2.12.0 -> 2.14.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 16, 2023, 8:15 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
-Support with_call for wrapped rpcs
-Update async client to use async retry
-Add caching to routing header calculation
-Add warning to retry target to avoid incorrect usage
-Drop usage of distutils
-Ensure exception is available when BackgroundConsumer open stream fails

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...gle-api-core_2.12.0.bb => python3-google-api-core_2.14.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-google-api-core_2.12.0.bb => python3-google-api-core_2.14.0.bb} (86%)

Comments

Khem Raj Nov. 20, 2023, 3:50 a.m. UTC | #1
On Thu, 16 Nov 2023 16:15:55 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ==========
> -Support with_call for wrapped rpcs
> -Update async client to use async retry
> -Add caching to routing header calculation
> -Add warning to retry target to avoid incorrect usage
> -Drop usage of distutils
> -Ensure exception is available when BackgroundConsumer open stream fails
> 
> [...]

Applied, thanks!

[1/1] python3-google-api-core: upgrade 2.12.0 -> 2.14.0
      commit: a8be218b216225d322456f023d33639fb87f8465

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-google-api-core_2.12.0.bb b/meta-python/recipes-devtools/python/python3-google-api-core_2.14.0.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-google-api-core_2.12.0.bb
rename to meta-python/recipes-devtools/python/python3-google-api-core_2.14.0.bb
index 28c6a7989..b620e553e 100644
--- a/meta-python/recipes-devtools/python/python3-google-api-core_2.12.0.bb
+++ b/meta-python/recipes-devtools/python/python3-google-api-core_2.14.0.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "c22e01b1e3c4dcd90998494879612c38d0a3411d1f7b679eb89e2abe3ce1f553"
+SRC_URI[sha256sum] = "5368a4502b793d9bbf812a5912e13e4e69f9bd87f6efb508460c43f5bbd1ce41"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-asyncio \