diff mbox series

[meta-python] python3-joblib: upgrade 1.2.0 -> 1.3.1

Message ID 1688699627-2519-17-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-joblib: upgrade 1.2.0 -> 1.3.1 | expand

Commit Message

Mingyu Wang (Fujitsu) July 7, 2023, 3:13 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Fix compatibility with python 3.7 by vendor loky 3.4.1 which is compatible
  with this version. #1472
-Ensure native byte order for memmap arrays in joblib.load. #1353
-Add ability to change default Parallel backend in tests by setting the
 JOBLIB_TESTS_DEFAULT_PARALLEL_BACKEND environment variable. #1356
-Fix temporary folder creation in joblib.Parallel on Linux subsystems on
 Windows which do have /dev/shm but don't have the os.statvfs function #1353
-Drop runtime dependency on distutils. distutils is going away in Python 3.12
 and is deprecated from Python 3.10 onwards.
-A warning is raised when a pickling error occurs during caching operations.
-Avoid (module, name) collisions when caching nested functions.
-Add cache_validation_callback in :meth:'joblib.Memory.cache', to allow custom
 cache invalidation based on the metadata of the function call. #1149
-Add a return_as parameter for Parallel, that enables consuming results
 asynchronously. #1393, #1458
-Improve the behavior of joblib for n_jobs=1, with simplified tracebacks and
 more efficient running time. #1393
-Add the parallel_config context manager to allow for more fine-grained control
 over the backend configuration.
-Add items_limit and age_limit in :meth:'joblib.Memory.reduce_size' to make it
 easy to limit the number of items and remove items that have not been accessed
 for a long time in the cache. #1200
-Deprecate bytes_limit in Memory as this is not automatically enforced, the
 limit can be directly passed to :meth:'joblib.Memory.reduce_size' which needs
 to be called to actually enforce the limit. #1447
-Vendor loky 3.4.0 which includes various fixes. #1422
-Various updates to the documentation and to benchmarking tools.
-Move project metadata to pyproject.toml. #1382, #1433
-Add more tests to improve python nogil support. #1394, #1395

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-joblib_1.2.0.bb => python3-joblib_1.3.1.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-joblib_1.2.0.bb => python3-joblib_1.3.1.bb} (80%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-joblib_1.2.0.bb b/meta-python/recipes-devtools/python/python3-joblib_1.3.1.bb
similarity index 80%
rename from meta-python/recipes-devtools/python/python3-joblib_1.2.0.bb
rename to meta-python/recipes-devtools/python/python3-joblib_1.3.1.bb
index ec02265d1e..9186cbb19f 100644
--- a/meta-python/recipes-devtools/python/python3-joblib_1.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-joblib_1.3.1.bb
@@ -4,7 +4,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2e481820abf0a70a18011a30153df066"
 
 inherit setuptools3 pypi
 
-SRC_URI[sha256sum] = "e1cee4a79e4af22881164f218d4311f60074197fb707e082e803b61f6d137018"
+SRC_URI[sha256sum] = "1f937906df65329ba98013dc9692fe22a4c5e4a648112de500508b18a21b41e3"
 
 RDEPENDS:${PN} += " \
     python3-asyncio \