diff mbox series

[meta-python] python3-django: upgrade 4.2.1 -> 4.2.2

Message ID 1686620422-29962-23-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-django: upgrade 4.2.1 -> 4.2.2 | expand

Commit Message

Mingyu Wang (Fujitsu) June 13, 2023, 1:40 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
- Fixed a regression in Django 4.2 that caused an unnecessary DBMS_LOB.SUBSTR()
  wrapping in the __isnull and __exact=None lookups for TextField()/BinaryField()
  on Oracle (#34544).
- Restored, following a regression in Django 4.2, get_prep_value() call in
  JSONField subclasses (#34539).
- Fixed a regression in Django 4.2 that caused a crash of QuerySet.defer() when
  passing a ManyToManyField or GenericForeignKey reference. While doing so is a
  no-op, it was allowed in older version (#34570).
- Fixed a regression in Django 4.2 that caused a crash of QuerySet.only() when
  passing a reverse OneToOneField reference (#34612).
- Fixed a bug in Django 4.2 where makemigrations --update didn't respect the
  --name option (#34568).
- Fixed a performance regression in Django 4.2 when compiling queries without
  ordering (#34580).
- Fixed a regression in Django 4.2 where nonexistent stylesheet was linked on a
  "Congratulations!" page (#34588).
- Fixed a regression in Django 4.2 that caused a crash of QuerySet.aggregate()
  with expressions referencing other aggregates (#34551).
- Fixed a regression in Django 4.2 that caused a crash of QuerySet.aggregate()
  with aggregates referencing subqueries (#34551).
- Fixed a regression in Django 4.2 that caused a crash of querysets on SQLite
  when filtering on DecimalField against values outside of the defined range (#34590).
- Fixed a regression in Django 4.2 that caused a serialization crash on a
  ManyToManyField without a natural key when its Manager's base QuerySet used select_related() (#34620).

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-django_4.2.1.bb => python3-django_4.2.2.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-django_4.2.1.bb => python3-django_4.2.2.bb} (58%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-django_4.2.1.bb b/meta-python/recipes-devtools/python/python3-django_4.2.2.bb
similarity index 58%
rename from meta-python/recipes-devtools/python/python3-django_4.2.1.bb
rename to meta-python/recipes-devtools/python/python3-django_4.2.2.bb
index b1474cf05..da65eb9c3 100644
--- a/meta-python/recipes-devtools/python/python3-django_4.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-django_4.2.2.bb
@@ -1,7 +1,7 @@ 
 require python-django.inc
 inherit setuptools3
 
-SRC_URI[sha256sum] = "7efa6b1f781a6119a10ac94b4794ded90db8accbe7802281cd26f8664ffed59c"
+SRC_URI[sha256sum] = "2a6b6fbff5b59dd07bef10bcb019bee2ea97a30b2a656d51346596724324badf"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-sqlparse \