diff mbox series

[meta-python] python3-lru-dict: upgrade 1.1.8 -> 1.2.0

Message ID 1685518820-20028-16-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-lru-dict: upgrade 1.1.8 -> 1.2.0 | expand

Commit Message

Mingyu Wang (Fujitsu) May 31, 2023, 7:40 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-lru-Use-PyCFunction-instead-of-PyCFunctionWithKeywor.patch
removed since it's included in 1.2.0

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ion-instead-of-PyCFunctionWithKeywor.patch | 37 -------------------
 ...ict_1.1.8.bb => python3-lru-dict_1.2.0.bb} |  4 +-
 2 files changed, 2 insertions(+), 39 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-lru-dict/0001-lru-Use-PyCFunction-instead-of-PyCFunctionWithKeywor.patch
 rename meta-python/recipes-devtools/python/{python3-lru-dict_1.1.8.bb => python3-lru-dict_1.2.0.bb} (64%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-lru-dict/0001-lru-Use-PyCFunction-instead-of-PyCFunctionWithKeywor.patch b/meta-python/recipes-devtools/python/python3-lru-dict/0001-lru-Use-PyCFunction-instead-of-PyCFunctionWithKeywor.patch
deleted file mode 100644
index b93d1594d..000000000
--- a/meta-python/recipes-devtools/python/python3-lru-dict/0001-lru-Use-PyCFunction-instead-of-PyCFunctionWithKeywor.patch
+++ /dev/null
@@ -1,37 +0,0 @@ 
-From 5013406c409a0a143a315146df388281bfb2172d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 1 Mar 2023 19:53:36 -0800
-Subject: [PATCH] lru: Use PyCFunction instead of PyCFunctionWithKeywords
-
-PyMethodDef uses PyMethodDef and not PyCFunctionWithKeywords and when
-callback is specified as PyCFunctionWithKeywords, clang 16+ is able to
-detect function signature mismatch in function pointers now.
-
-Fixes
-lru.c:629:17: error: incompatible function pointer types initializing 'PyCFunction' (aka 'struct _object *(*)(struct _object *, struct _object *)') with an expression of type 'PyCFunctionWithKeywords' (aka 'struct _object *(*)(struct _object *, struct _object *, struct _object *)') [-Wincompatible-function-pointer-types]
-    {"popitem", (PyCFunctionWithKeywords)LRU_popitem, METH_VARARGS | METH_KEYWORDS,
-                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-1 error generated.
-
-Upstream-Status: Submitted [https://github.com/amitdev/lru-dict/pull/45]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- lru.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lru.c b/lru.c
-index 8adcb4b..33c18ab 100644
---- a/lru.c
-+++ b/lru.c
-@@ -626,7 +626,7 @@ static PyMethodDef LRU_methods[] = {
-                     PyDoc_STR("L.setdefault(key, default=None) -> If L has key return its value, otherwise insert key with a value of default and return default")},
-     {"pop", (PyCFunction)LRU_pop, METH_VARARGS,
-                     PyDoc_STR("L.pop(key[, default]) -> If L has key return its value and remove it from L, otherwise return default. If default is not given and key is not in L, a KeyError is raised.")},
--    {"popitem", (PyCFunctionWithKeywords)LRU_popitem, METH_VARARGS | METH_KEYWORDS,
-+    {"popitem", (PyCFunction)LRU_popitem, METH_VARARGS | METH_KEYWORDS,
-                     PyDoc_STR("L.popitem([least_recent=True]) -> Returns and removes a (key, value) pair. The pair returned is the least-recently used if least_recent is true, or the most-recently used if false.")},
-     {"set_size", (PyCFunction)LRU_set_size, METH_VARARGS,
-                     PyDoc_STR("L.set_size() -> set size of LRU")},
--- 
-2.39.2
-
diff --git a/meta-python/recipes-devtools/python/python3-lru-dict_1.1.8.bb b/meta-python/recipes-devtools/python/python3-lru-dict_1.2.0.bb
similarity index 64%
rename from meta-python/recipes-devtools/python/python3-lru-dict_1.1.8.bb
rename to meta-python/recipes-devtools/python/python3-lru-dict_1.2.0.bb
index e825e43df..7a3a17274 100644
--- a/meta-python/recipes-devtools/python/python3-lru-dict_1.1.8.bb
+++ b/meta-python/recipes-devtools/python/python3-lru-dict_1.2.0.bb
@@ -4,8 +4,8 @@  SECTION = "devel/python"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=9d10a486ee04034fdef5162fd791f153"
 
-SRC_URI[sha256sum] = "878bc8ef4073e5cfb953dfc1cf4585db41e8b814c0106abde34d00ee0d0b3115"
+SRC_URI[sha256sum] = "13c56782f19d68ddf4d8db0170041192859616514c706b126d0df2ec72a11bd7"
 
 inherit pypi setuptools3
 
-SRC_URI += "file://0001-lru-Use-PyCFunction-instead-of-PyCFunctionWithKeywor.patch"
+SRC_URI += "${PYPI_SRC_URI}"